Bug #66561 Trying edit table from diagram
Submitted: 28 Aug 2012 1:56 Modified: 28 Sep 2012 19:56
Reporter: Mauricio Aimola Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.42 OS:Windows (Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[28 Aug 2012 1:56] Mauricio Aimola
Description:
When editing a table from diagram

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.42  revision 9752
Configuration Directory: C:\Users\Mauricio\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
CPU: 4x AMD Athlon(tm) II X4 620 Processor, 3.9 GiB RAM
Active video adapter (0): NVIDIA GeForce 7025 / NVIDIA nForce 630a
Installed video RAM: 128 MB
Current video mode: 1440 x 900 x 4294967296 colors
Used bit depth: 32
Driver version: 8.17.12.5896
Installed display drivers: nvd3dumx.dll,nvd3dum
Current user language: Português (Brasil)

Exception = System.InvalidCastException
Message = Não é possível converter um objeto do tipo 'MySQL.Forms.AppViewImpl' no tipo 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Não é possível converter um objeto do tipo 'MySQL.Forms.AppViewImpl' no tipo 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   em MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   em MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   em MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   em boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   em wb.WBContext.flush_idle_tasks(WBContext* )
   em MySQL.Workbench.WbContext.flush_idle_tasks()
   em MySQL.GUI.Workbench.Program.timer_Tick(Object sender, EventArgs e)

How to repeat:
Double click in table name
[28 Aug 2012 19:56] Armando Lopez Valencia
Hello.
Can you please try checking the "Force use of software base rendering for EER Diagrams" in EDIT->Preferences->General and let us know if it fix your problem?
Thanks
[29 Sep 2012 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".