Bug #66559 Object Info tab - allow to see natural order (unsorted) column list of a table
Submitted: 27 Aug 2012 21:49 Modified: 28 Aug 2012 4:07
Reporter: Walter K Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.42 CE r9752 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[27 Aug 2012 21:49] Walter K
Description:
When a table is selected in the Object Browser, corresponding Object Info tab displays table columns sorted alphabetically. Often natural order (i.e. logical grouping) of columns in a table makes more sense.

Relevant forum post: http://forums.mysql.com/read.php?152,566031,566378

How to repeat:
1. Open SQL Editor.
2. In the Object Browser, expand a database and select a table
3. Object Info tab below the Object Browser shows table's columns sorted alphabetically.

Suggested fix:
Object Info tab displayed columns unsorted as of MySQL Workbench 5.2.38. 

There needs to be a toggle button, a la Eclipse Outline view, to choose between sorted and unsorted column display in the Object Info tab.

Alternately, table columns can be displayed unsorted by default.
[28 Aug 2012 4:07] Alfredo Kojima
duplicate of bug #66232