Bug #66442 metadata
Submitted: 17 Aug 2012 21:56 Modified: 21 Aug 2012 14:23
Reporter: Raffaele Liverani Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / J Severity:S3 (Non-critical)
Version:5.1.21 OS:Microsoft Windows
Assigned to: Alexander Soklakov

[17 Aug 2012 21:56] Raffaele Liverani
Description:
DatabaseMetadata().getTables(catalog, schema, table, null)

colum 'REMARKS' is always empty, even though the table has a comment

How to repeat:
DatabaseMetadata().getTables(catalog, schema, table, null)
[21 Aug 2012 7:16] Alexander Soklakov
Hello Raffaele,

Please, try to use useInformationSchema=true.
[21 Aug 2012 8:55] Raffaele Liverani
Hello Alexander,
I use MySQL 5.5.27
If I set the parameter useInformationSchema = true metadata are correct , but in the documentation this parameter should be the default to false ...
thanks
[21 Aug 2012 9:57] Alexander Soklakov
Raffaele,

Documentation doesn't say what parameter value should be, it just says what the default is. But I agree, we should mention somewhere in documentation that for newer server versions the useInformationSchema=true is preferred.
[21 Aug 2012 14:25] Alexander Soklakov
This is duplicate of http://bugs.mysql.com/bug.php?id=65213