Bug #66380 crash on sync model
Submitted: 14 Aug 2012 15:26 Modified: 22 Aug 2012 16:38
Reporter: Bogdan Fürst Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Ultimate Edition (build 7600), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[14 Aug 2012 15:26] Bogdan Fürst
Description:
occured for first time

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\AI\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Ultimate Edition (build 7600), 64-bit
CPU: 8x Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz, 6.0 GiB RAM
Active video adapter (0): ATI Radeon HD 5800 Series
Installed video RAM: 1024 MB
Current video mode: 1920 x 1200 x 4294967296 colors
Used bit depth: 32
Driver version: 8.980.0.0
Installed display drivers: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Current user language: Slovenian (Slovenia)

Exception = System.Threading.ThreadStateException
Message = Thread is running or terminated; it cannot restart.
FullText = System.Threading.ThreadStateException: Thread is running or terminated; it cannot restart.
   at System.Threading.Thread.StartInternal(IPrincipal principal, StackCrawlMark& stackMark)
   at System.Threading.Thread.Start(StackCrawlMark& stackMark)
   at System.Threading.Thread.Start()
   at Aga.Controls.Tree.NodeControls.ExpandingIcon.Start()
   at Aga.Controls.Tree.TreeViewAdv.AddExpandingNode(TreeNodeAdv node)
   at Aga.Controls.Tree.TreeViewAdv.SetIsExpanded(TreeNodeAdv node, Boolean value)
   at Aga.Controls.Tree.TreeViewAdv.SetIsExpanded(ExpandArgs eargs)
   at Aga.Controls.Tree.TreeViewAdv.<SetIsExpanded>b__1b(Object argument)
   at Aga.Controls.Threading.AbortableThreadPool.<>c__DisplayClass5.<HandleItem>b__3(Object )
   at System.Threading.ExecutionContext.runTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at Aga.Controls.Threading.AbortableThreadPool.HandleItem(Object ignored)
   at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

How to repeat:
no idea
[14 Aug 2012 16:16] MySQL Verification Team
Please check if 5.2.42 fixes that issue. Thanks.
[20 Aug 2012 2:29] Bogdan Fürst
hasn't occured yet in 5.2.42, but may be related to 
http://bugs.mysql.com/bug.php?id=66459
[22 Aug 2012 16:38] Alfredo Kojima
Duplicate of bug #66459