Bug #66342 error handler does not disable report bug option after already used
Submitted: 12 Aug 2012 21:53 Modified: 14 Aug 2012 19:37
Reporter: Brant Gurganus Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Workbench Severity:S4 (Feature request)
Version:5.2.41 CE OS:Microsoft Windows (8 Consumer Preview)
Assigned to: CPU Architecture:Any

[12 Aug 2012 21:53] Brant Gurganus
Description:
When an unexpected error occurs, there is a prompt to report the issue. After the issue is reported, the report option is still available inviting the opportunity to submit duplicates of the issue and confuse the user.

How to repeat:
1. Do something that causes an unexpected error.
2. Report issue.
3. Report issue again.

Suggested fix:
After successfully reporting issue, disable the "Report Bug" option.
[12 Aug 2012 21:58] Brant Gurganus
I corrected the OS field to indicate this occurs in Windows. I confirmed that within the same Workbench session, the issue is reproducible. After exiting and restarting, it is not obviously reproducing.
[14 Aug 2012 19:12] Alfredo Kojima
This would be a nice feature, but because there is no way to know when a specific bug was already reported before, it is not possible to be implemented.
[14 Aug 2012 19:37] Brant Gurganus
I don't think that's accurate. You don't know if an issue is already reported to Bugzilla but you can know whether that occurence has been reported. You should be able to click Report. Send report. Button gets disabled. It sounded like perhaps you misunderstood that it should disable if already reported to Bugzilla which I agree wouldn't be easy to do, if possible. However, disabled after reporting that occurence should be reasonably doable.