Bug #66191 无法将类型为“mysql.forms.menuitemimpl”的对象强制转换为类型“mysql.gui.workbench.plugins.dockablep
Submitted: 4 Aug 2012 2:09 Modified: 4 Aug 2012 8:02
Reporter: yang cougar Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Ultimate Edition (build 7600), 32-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[4 Aug 2012 2:09] yang cougar
Description:
无法将类型为“mysql.forms.menuitemimpl”的对象强制转换为类型“mysql.gui.workbench.plugins.dockableplugin”

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\Uiin\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Ultimate Edition (build 7600), 32-bit
CPU: 4x Intel(R) Core(TM) i5-2557M CPU @ 1.70GHz, 2.2 GiB RAM
Active video adapter (0): Intel(R) HD Graphics Family
Installed video RAM: 916 MB
Current video mode: 1440 x 900 x 4294967296 colors
Used bit depth: 32
Driver version: 8.15.10.2430
Installed display drivers: igdumdx32.dll,igd10umd32.dll,igd10umd32.dll
Current user language: 中文(简体,中国)

Exception = System.InvalidCastException
Message = 无法将类型为“MySQL.Forms.MenuItemImpl”的对象强制转换为类型“MySQL.GUI.Workbench.Plugins.DockablePlugin”。
FullText = System.InvalidCastException: 无法将类型为“MySQL.Forms.MenuItemImpl”的对象强制转换为类型“MySQL.GUI.Workbench.Plugins.DockablePlugin”。
   在 MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   在 MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   在 MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   在 boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   在 wb.WBContext.flush_idle_tasks(WBContext* )
   在 MySQL.Workbench.WbContext.flush_idle_tasks()
   在 MySQL.GUI.Workbench.Program.timer_Tick(Object sender, EventArgs e)

How to repeat:
无法将类型为“mysql.forms.menuitemimpl”的对象强制转换为类型“mysql.gui.workbench.plugins.dockableplugin”
[4 Aug 2012 8:02] Valeriy Kravchuk
This is a duplicate of bug #66013.