Bug #66037 can't edit a table more than once
Submitted: 26 Jul 2012 21:22 Modified: 26 Jul 2012 21:28
Reporter: Daniel L. Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows Server 2008 R2 Standard Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[26 Jul 2012 21:22] Daniel L.
Description:
I can't edit a table in the diagram editor because the tab (where I can edit columns and such) wont open again once it was closed.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\xcoder\AppData\Roaming\MySQL\Workbench
Data Directory: E:\Tools\MySQL Workbench
Cairo Version: 1.8.8
OS: Microsoft Windows Server 2008 R2 Standard Edition Service Pack 1 (build 7601), 64-bit
CPU: 4x Intel(R) Core(TM)2 Quad CPU    Q8400  @ 2.66GHz, 7.9 GiB RAM
Active video adapter (0): Intel(R) Q45/Q43 Express Chipset
Installed video RAM: -277 MB
Current video mode: 1024 x 768 x 4294967296 Farben
Used bit depth: 32
Driver version: 8.15.10.2189
Installed display drivers: igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
Current user language: Deutsch (Deutschland)

Exception = System.InvalidCastException
Message = Das Objekt des Typs "MySQL.Forms.ToolBarItemImpl" kann nicht in Typ "MySQL.GUI.Workbench.Plugins.DockablePlugin" umgewandelt werden.
FullText = System.InvalidCastException: Das Objekt des Typs "MySQL.Forms.ToolBarItemImpl" kann nicht in Typ "MySQL.GUI.Workbench.Plugins.DockablePlugin" umgewandelt werden.
   bei MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   bei MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   bei MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   bei boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   bei wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   bei MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   bei MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   bei System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   bei MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   bei System.Windows.Forms.Control.WndProc(Message& m)
   bei System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Edit a table in the diagram editor, close the edit tab and try to reopen it by editing the same table again, most times it won't the tab again.
[26 Jul 2012 21:28] Daniel L.
Sorry, my bug report is a duplicate of Bug #66021