Bug #65947 windows 2003 use mysql 5.6 tell me 1067 error,and can't start
Submitted: 19 Jul 2012 6:15 Modified: 19 Jul 2012 12:39
Reporter: darkz hei Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:mysql-5.6.6-labs-june-2012-win32 OS:Microsoft Windows (windows 2003 with sp2 32 bit)
Assigned to: CPU Architecture:Any
Tags: 1067

[19 Jul 2012 6:15] darkz hei
Description:
    When I know the new mysql version is published in http://labs.mysql.com,I download the mysql-5.6.6-labs-june-2012-win32.zip and extrat it on my windows server 2003 with sp2 32 bit,use the configure file my.ini form the older GA version mysql 5.5.25a
    then register as a system service,the press the button to start the mysql service,sadly,it say error,1067,the process terminated!!
    what on the log file says:

......
120719 13:56:24 [Note] Server hostname (bind-address): '::'; port: 3306
120719 13:56:26 [ERROR] Can't create IP socket: No error
120719 13:56:26 [ERROR] Can't start server: cannot resolve hostname!
120719 13:56:26 [ERROR] Aborting
......

I don't know why....

After I search google for times,it still can't work!
Suddenly,I found that : let me bind the service to a IP address to test?
After I added 

bind-address=0.0.0.0

to the configure file my.ini,restart the service.
What a sunny day!!!

How to repeat:
On windows server 2003 sp2 32bit,download the mysql-5.6.6-labs-june-2012-win32.zip from http://labs.mysql.com,use the configure file without "bind-address=x.x.x.x" in it ,the error appear!!!

Suggested fix:
when the mysqld.exe can't find the "bind-address=x.x.x.x" in the config file ,use "bind-address=0.0.0.0" default.
[19 Jul 2012 9:18] Shane Bester
You probably don't have IPV6 enabled.  This bug has already been addressed in the source code, so shouldn't be a problem in the actual release.
[19 Jul 2012 9:40] darkz hei
It will be fix ?That's a good news.
But I think it should be write to the log file clearly,or others will not easy to how to resolve the small problem.

I think it's not a big probles for you.

And there is not a configure tools MySQLInstanceConfig.exe in the zip file.
Could you add this tool to the package for the new version of mysql??
[19 Jul 2012 10:20] Shane Bester
So this is a duplicate of:
Bug 14141670 - SERVER DON'T START ON WINDOWS: CAN'T CREATE IP SOCKET: NO SUCH FILE OR DIRECTORY

Current version from source code looks like this, notice the difference:

120719 12:18:02 InnoDB: highest supported file format is Barracuda.
120719 12:18:04 InnoDB: 128 rollback segment(s) are active.
120719 12:18:04 InnoDB: Waiting for the background threads to start
120719 12:18:04 InnoDB: 1.2.7 started; log sequence number 1629582
120719 12:18:05 [Note] Server hostname (bind-address): '*'; port: 3306
120719 12:18:07 [Note] IPv6 is not available.
120719 12:18:07 [Note]   - '0.0.0.0' resolves to '0.0.0.0';
120719 12:18:07 [Note] Server socket created on IP: '0.0.0.0'.
120719 12:18:10 [Note] mysqld-debug: ready for connections.
Version: '5.6.7-debug'  socket: ''  port: 3306  MySQL Community Server (GPL)
[19 Jul 2012 12:39] darkz hei
I couldn't find out where the "Bug 14141670" is...
what the log says seems to be ok ,I think...
[24 Jul 2012 13:33] Sámuel Velkey
Hi! 

I have run the innodb_memcached_config.sql succesfully, but after that i can't go on. I can't install the daemon_memcached plugin. I saw some examples from linux, and there is a .so file to use this purpose. Anybody has any idea how to go further?