Bug #659 mysqldump with 3.23.49 has missing data when imported into 4.0.13
Submitted: 16 Jun 2003 6:34 Modified: 16 Jul 2003 13:26
Reporter: Keith Winton Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Server: mysqldump Command-line Client Severity:S2 (Serious)
Version:4.0.13 OS:Microsoft Windows (win32)
Assigned to: CPU Architecture:Any

[16 Jun 2003 6:34] Keith Winton
Description:
We have been encountering odd, random cases where a MYSQLDUMP created from v 3.23.49 will not load all data when imported into v 4.0.13.  It loads fine into v 4.0.12.  No errors are generated, nor any indication that some of the data is not loaded.  Some tables are just empty.  If you care for any more details, or would like a copy of the mysql dump, let me know.  We're doing these commands from a DOS box on Win XP:  "mysqldump --opt dbname > script.sql", and then "mysql dbname < script.sql".  When we over-write the 4.0.13 version with 4.0.12, it works fine.  

How to repeat:
I can send you the mysqldump file if you'd like.
[16 Jun 2003 7:00] Miguel Solorzano
Could you please upload the test case at:

ftp://support.mysql.com/pub/mysql/secret

Use a zip file with identification for this bug.
[16 Jun 2003 7:23] Keith Winton
Just uploaded zip file of mysql dump.  Let me know if you need anything else.  FYI, to identify the problem, we did a lot of "testing", like deleting the DB, deleting the tables that had the problem, etc, and it was always repeatable.  I also re-installed 4.0.13 just in case, but the problem was still there.  Once I "downgraded" to 4.0.12, it worked just fine.
[16 Jun 2003 13:19] Alexander Keremidarski
Keith,

I tested it with 4.0.12, pre-4.0.14 and pre-3.23.57 (both from BK tree) and got exactly the same result with all of them. Can you tell us more about what exactly the difference is?

I tested it with Importing to all three databases, then mysqldump --opt and diff between dumps. The only difference is MySQL version number.

Can you please try prepring smaller test case - just tables which appear to be different on 4.0.12 and 4.0.13. One or two tables are enough.

It will be best if you can send us original dumpfile from 3.23.49, dumps from both 4.0.12 and 4.0.13 (they should be different) and Tables themselves.
[16 Jun 2003 13:26] Keith Winton
Sure...I'll just pick out one of the tables that didn't work, and make sure I can recreate it on my local system.  It will probably be later tomorrow when I get it to you, so that I have time to test it.
[14 Feb 2005 22:54] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".