Bug #65830 utf8_general_cs is not available
Submitted: 5 Jul 2012 20:33 Modified: 14 Mar 2017 8:10
Reporter: Davi Arnaut (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:5.5.25 OS:Any
Assigned to: CPU Architecture:Any
Tags: collation, Contribution, regression, utf8_general_cs
Triage: Needs Triage: D3 (Medium)

[5 Jul 2012 20:33] Davi Arnaut
Description:
The utf8_general_cs collation is not being compiled in MySQL 5.5. The problem is that although the collation is enabled in CMake, the configuration option is not copied over to the configuration header (e.g. config.h).

How to repeat:
CREATE TABLE t1 (a INT, b TEXT) CHARSET=utf8 COLLATE=utf8_general_cs;
[5 Jul 2012 21:00] Davi Arnaut
Compile in the utf8_general_cs collation.

(*) I confirm the code being submitted is offered under the terms of the OCA, and that I am authorized to contribute it.

Contribution: Bug#65830-utf8_general_cs-is-not-available.patch (application/octet-stream, text), 796 bytes.

[5 Jul 2012 21:03] Davi Arnaut
Collation is available in MySQL 5.1
[5 Jul 2012 21:05] Davi Arnaut
In light of Bug#50909 and it being an experimental collation, perhaps a better option would be actually remote it.

Also, see Bug#38697 for this very same problem.
[5 Jul 2012 21:06] Davi Arnaut
Also, Bug#63164, which is a duplicate of this one.
[22 Apr 2014 22:13] Jeremy Cole
What's going on here?
[14 Mar 2017 8:07] Manyi Lu
A accent and case sensitive collation for ut8mb4 will be made available in 8.0.