Bug #65789 server instance configuration wizard hangs
Submitted: 2 Jul 2012 20:50 Modified: 27 Sep 2012 19:16
Reporter: Bogdan Fürst Email Updates:
Status: Closed Impact on me:
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:5.5.18+ OS:Windows (win7, x64)
Assigned to: CPU Architecture:Any
Tags: installer, setup, windows service

[2 Jul 2012 20:50] Bogdan Fürst
This used to work in february, i think last working version was 5.5.18
After that, i cannot install mysql server as windows service at all.
No forum discussion on this on www solves this problem, despite trying...
No relevant log data is generated and the service cannot be started at all: error 1067, process terminated unexpectedly.

How to repeat:
Download mysql community server setup.
Run setup and keep everything default, except in security:
- set root password
- allow remote hosts
When server instance configuration wizard presents 'Execute' button, click it.

-> Wizard hangs on second step: 'write my.ini' (see picture)

Suggested fix:
Problem only occurs when Install as windows service is selected, so it's probably a permission-related problem. Since i have tens of dev tools installed on the same machine and working properly, i deduce it's a bug in wizard.

A detailed log would come handy as noone seems to be able to find out what the problem is in the first place (the whole community seems to be guessing blindly).

Install MySQL on linux/unix virtual machine (acceptable only when client is familiar with management of a virtual machine)
[2 Jul 2012 20:54] Bogdan Fürst
wizard hang

Attachment: Clipboard02.jpg (image/jpeg, text), 67.37 KiB.

[3 Jul 2012 1:04] MySQL Verification Team
Thank you for the bug report. That was a fresh install (i.e: without prior data directory or my.ini file)?. Thanks.
[3 Jul 2012 13:02] Bogdan Fürst
Not a fresh install. 
- first time install, 5.5.18 on target machine (sometime in February 2012 or beginning of March 2012)
- update via automatic update to 5.5.19
- update via automatic update to 5.5.20

// i do not recall if i ever updated to 5.5.21

- attempt update via automatic update to 5.5.22, reported success, but version number did not change (remained 5.5.22)
- retry update to 5.5.22 via automatic update, same result
- uninstall
- retry install 5.5.22 -> cannot get MySQL 5.5.xx to work anymore, not even the latest dev milestone (5.6.?.m8)

I tried cleaning up files and registry, but there is a possibility i missed something relevant.
[3 Jul 2012 13:08] Bogdan Fürst
... Workbench and .Net Connector work fine
Thank you for swift reply.
[17 Jul 2012 8:24] Bogdan Fürst
found some event log entries:

1 (time: 20:39:07)
The program MySQLInstanceConfig.exe version stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
 Process ID: edc
 Start Time: 01cd5ecaf2478976
 Termination Time: 3
 Application Path: C:\Program Files\MySQL\MySQL Server 5.5\bin\MySQLInstanceConfig.exe
 Report Id: 8436b872-cabe-11e1-8dc1-e0cb4e7b07d0

2 (time: 20:40:06)
The following information was included with the event: 
Plugin 'InnoDB' init function returned error.

3 (time: 20:40:06)
The following information was included with the event: 
Plugin 'InnoDB' registration as a STORAGE ENGINE failed.

4 (time: 20:40:06)
The following information was included with the event: 
Unknown/unsupported storage engine: INNODB

5 (time: 20:40:06)
The following information was included with the event: 
[17 Jul 2012 10:28] Bogdan Fürst
found a workaround, which is a bit painfull:
- uninstall all mysql products
- uninstall Microsoft Web Platform Installer (not really sure if this is related)
- delete anything left on filesystem by this products
- clear all windows temp directories
- search registry for string 'mysql' and delete everything that seems to belong to mysql products
- reboot
- install mysql server and select 'Typical'
- install .net connector 
- install workbench

service seems to work fine now and is accessible through workbench
[22 Sep 2012 2:02] MySQL Verification Team
I can't repeat with 5.5.27. Please try it. Thanks.
[27 Sep 2012 19:16] Bogdan Fürst
Mysql installer product does NOT work at all after first use. First install is ok, but every reuse breaks everything so badly it cannot be fixed other than cleaning up registry of all mysql stuff. This bug report is only one of detected issues.
And no, it's not my registry that's mixed up. MySql stuff is the only widespread tech on my dev machine that causes trouble almost all the time.
10% of all work hours spent on my last project were used on workbench crashes and server installer leech coctail.

Since no one seems to be testing windows setups by reinstalling, updating and cleaning up mysql products on windows 7, I give up on this topic and will use the only workaround possible: make sure i do not use installer.
[16 Oct 2012 19:27] danny vogler
It's very important to also remove C:\ProgramData\MySQL folder.

I've experienced this problem several times, following uninstall instructions from all over the web without any luck, until now.

This folder is typically hidden, so manually navigate to C:\ProgramData and delete the entire MySQL directory. Re-install and hope for the best.
[13 Aug 2013 19:28] pj villarta
i am trying to install mysql 5.5.33 and encountered this exact same problem of the configuration wizard hanging. i suppose this bug still has not been addressed. 

thank you for the workaround shared. will try and hope it works.
[13 Aug 2013 20:16] pj villarta
the solutions posted here http://bugs.mysql.com/bug.php?id=48871 have helped me get by this problem.
[21 Aug 2013 18:07] Phil Maidlow
None of the suggestions here worked for me (Windows 7 x64). I did get MySql installed and running as a service by downloading and installing a previous version (5.1.68). The previous version was also 32 bit as opposed to the current 64 bit.