Bug #65707 Alter Table option does nothing
Submitted: 22 Jun 2012 8:41 Modified: 12 Jul 2012 14:11
Reporter: Jean-Yves Rouffiac Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.40 OS:Mac OS X (10.7.4)
Assigned to: CPU Architecture:Any
Tags: ALTER TABLE, Lion, os x, sql editor

[22 Jun 2012 8:41] Jean-Yves Rouffiac
Description:
Hi,

I'm not sure if this is specific to this install or whether this issue migtht affect others too, so I am raising it as a bug. 

I installed WB 5.2.40 (rev 8790) on an iMac 2.5Ghz, i5, OS X Lion 10.7.4. 

All seems good except that nothing happens when I click the Alter Table popup-menu option. No message, no screen flicker, nothing at all. I have tried with the mouse and using the keyboard.

Other menu options (Select Rows, Create Table, Edit Data, Copy, Send, Refresh, Drop) all work fine. 

MySQL version: 5.1.63 64-bit from mysql.com (mysql-5.1.63-osx10.6-x86_64.dmg)

Note: There was an old MySQL 5.0.x version on this system which had been installed using MacPorts, but that had been uninstalled (using the port uninstall command) before I then installed the binary package from mysql.com. Not sure whether this may be a relevant factor or not?

Altering the table using ALTER TABLE commands works fine of course, as does editing the tables via the UI of another tool, eg Sequel Pro

A colleague who has 5.2.40 installed on OS X 10.6.8 reports that he is unaffected by this issue.

Is there a log file I could provide you with that would help to identify the cause of this issue?

I noticed that there was another bug raised for OS X Lion whereby clicking on Alter Table crashes the Mac (but that is on 10.7.3).  
http://bugs.mysql.com/bug.php?id=65606
They might possibly be related?

How to repeat:
Click on Alter Table.  Nothing happens.
[3 Jul 2012 2:04] Alfredo Kojima
There are log files in ~/Library/Logs/DiagnosticReports and ~/Library/Application Support/MySQL/Workbench/logs/
[3 Jul 2012 7:55] Jean-Yves Rouffiac
Thanks. I closed down WB, started it up to again to get a fresh set of logs and here is what I have ~/Library/Application Support/MySQL/Workbench/login wb.log:

08:47:55 [INF][      Workbench]: Starting up Workbench
08:47:55 [INF][      Workbench]: Loading main window
08:47:55 [INF][      WBContext]: WbContext::init
08:47:56 [WRN][            grt]: Could not load db.mysql.editors.wbp.dylib: Duplicate module MySQLEditorsModule    Could not load wb.mode$
        MySQL Workbench CE for Mac OS X version 5.2.40  revision 8790
        Configuration Directory: /Users/jrouffiac/Library/Application Support/MySQL/Workbench
        Data Directory: /Applications/MySQLWorkbench.app/Contents/Resources
        Cairo Version: 1.9.1
        OS: Darwin 11.4.0
        CPU: 4x Intel(R) Core(TM) i5-2400S CPU @ 2.50GHz, 8.0 GB RAM
08:47:59 [INF][     SSH tunnel]: Starting tunnel

I am also getting a *lot* of the following when I look at the older log files even though I have only gone through the Server Admin wizard 2 times:
10:54:35 [WRN][               ]: Trying to turn past the last page of the wizard

I don't have any Workbench-related logs in ~/Library/Logs/DiagnosticReports

Hope this helps.
[3 Jul 2012 13:08] Alfredo Kojima
Did you try opening the ALTER table editor before getting the log files?
[3 Jul 2012 13:46] Jean-Yves Rouffiac
Yes.
[3 Jul 2012 14:51] Jean-Yves Rouffiac
Hi ALfredo

I have found the reason:

there was a database in the /usr/local/mysql/data directory called 'mysql.old'

When I moved that database out of the directory, it worked again.  I figured this out by reading through http://bugs.mysql.com/bug.php?id=62686 and seeing the reference to corrupt system tables.

Maybe a check could be done by Workbench to make sure it is looking at the correct 'mysql' database if more than one database exists in the data folder which starts with those characters?

Thanks very much for assisting me with this issue by the way - as ever, I am hugely indebted to all the people who make MySQL and the associated products such a great suite of tools.
[12 Jul 2012 14:11] Alfredo Kojima
There's nothing we can do about that from WB, we can only work with MySQL server responses.