Bug #65630 MySQL Workbench has stopped working
Submitted: 15 Jun 2012 17:41 Modified: 4 Feb 2013 19:30
Reporter: Mark Fulford Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.40 OS:Windows (Win 7 64-bit)
Assigned to: CPU Architecture:Any
Tags: resolved

[15 Jun 2012 17:41] Mark Fulford
MySQL Workbench hangs at the splash screen. I have tried restarting, reinstalling Workbench, disabling antivirus and from the cmd line with the -swrendering switch.

Debugging via VS2010 gives
"An unhandled Microsoft .NET Framework exception occurred in MySQLWorkbench.exe [3384]"

The application log lists 2 relevant errors.

First error:

Application: MySQLWorkbench.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0000005, exception address 100B954E

Second error:

Faulting application name: MySQLWorkbench.exe, version:, time stamp: 0x4fa2f938
Faulting module name: wbprivate.be.dll, version:, time stamp: 0x4fa2f597
Exception code: 0xc0000005
Fault offset: 0x000b954e
Faulting process id: 0x1390
Faulting application start time: 0x01cd4b1d66299c45
Faulting application path: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\MySQLWorkbench.exe
Faulting module path: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\wbprivate.be.dll
Report Id: a5791955-b710-11e1-b247-005056c00008

How to repeat:
Start MySQL Workbench
[15 Jun 2012 17:58] Valeriy Kravchuk
Please attach the log files at C:\Users\<your user id>\AppData\Roaming\MySQL\Workbench\wb.log. Check similar bug #63909 also.
[18 Jun 2012 11:15] Mark Fulford
Issue resolved by end-user as follows:

1. Uninstall MySQL Workbench.

2. Rename C:\Users\<your user id>\AppData\Roaming\MySQL\Workbench\
   to C:\Users\<your user id>\AppData\Roaming\MySQL\Workbench\

3. Reinstall Workbench.
[18 Jun 2012 11:18] Mark Fulford
Sorry, renamed folder meant to be:

C:\Users\<your user id>\AppData\Roaming\MySQL\Workbench_old\
[20 Jun 2012 17:42] Armando Lopez Valencia
Hello Mark.
This looks really interesting, can you please provide us the content of the "C:\Users\<your user id>\AppData\Roaming\MySQL\Workbench_old\" folder?
[21 Jul 2012 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[4 Aug 2012 15:29] Miguel Martin
Great great great!! Thanks a lot!! That was making me go crazy...
My story is that workbench stopped working after a computer battery disconnection when workbench was opened. After this, tried to reinstall every component (.net, vc++ and workbench) but always same error.

Attached the content of the folder.
[7 Aug 2012 12:04] MySQL Verification Team
Please try version 5.2.41. Thanks.
[20 Aug 2012 22:18] A Biyi
On my Windows 7 64bit, when I was trying to export my ER Diagram into PNG or PDF I got the same "MySQL Workbench has stopped working" Error.   After a quick internet search with no luck I decided to see if I rerun the application in XP compatibility mode will solve the problem.  Yes indeed, it solved the problem.  Here is how I did it.

1. Close (all instances of) MySQL Workbench application if it is currently running
2. Right click on the MySQL Workbench application then select Properties
3. Click on the Compatibility tab
4. Check the Checkbox for "Run this program in compatibility mode for:"  then select Windows XP (Service Pack 3) option in the drop down list
5. Click OK
6. Then fire up MySQL Workbench and re-do the operation that oreviously gave you the error "MySQL Workbench has stopped working"  

The operation should now run successfully w/o crashing.  That was my case. I hope it works for you too.  Good luck
[31 Aug 2012 5:07] Michael Chang
It happened on mine (Lenovo Y470, Quad Core i7, 8GB RAM)

and after reinstall / restart didn't solve the issue, I turned off the graphics accelerator (from nVidia GT500M to Intel HD3000) and it just worked again.  

Didn't need to run in XP compatibility mode.
[14 Jan 2013 4:14] Christopher Thomas
I had the same error appearing in event viewer referencing the module wbprivate.be.dll.  Thanks Mark for your fix, renaming and reinstalling worked wonderfully.
[2 Feb 2013 16:58] Tony Lu
Turning off the graphics accelerator exactly worked!
I'm wondering how you could find the solution.
[4 Feb 2013 19:30] Philip Olson
Fixed as of the upcoming MySQL Workbench 5.2.46, and here's the changelog entry:

MySQL Workbench could crash after files became corrupted, but now attempts to
regenerate the corrupted files.

Thank you for the bug report.
[28 Aug 2013 12:32] Mattias Johnsson
This error seems to be valid in version 6.0.6 as well;
MySQL Workbench crashed when fumbling with a file and then crashed every time I tried to open Workbench.

After deleting the file Workbench started to work again.
[28 Aug 2013 15:08] Mike Lischke
Please don't hijack an already closed bug. Your problem, even though it might look similar, has probably other causes. So please open a new bug report with a good description what you did.