Bug #65541 Partitioning + Query Cache
Submitted: 6 Jun 2012 18:05 Modified: 12 Jul 2012 2:03
Reporter: Todd Wade Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version:5.1, 5.5, 5.6 OS:Any
Assigned to: Jon Stephens CPU Architecture:Any
Tags: partitioning, query cache
Triage: Needs Triage: D3 (Medium)

[6 Jun 2012 18:05] Todd Wade
Description:
Spent quite a bit of time examining partitioning and porting my app to partitions, only to find out my queries weren't being cached in the query cache. After searching around I found the cache was disabled for http://bugs.mysql.com/bug.php?id=53775

I think this is a huge limitation and should be listed at http://dev.mysql.com/doc/refman/5.6/en/partitioning-limitations.html

http://dev.mysql.com/doc/refman/5.5/en/query-cache-operation.html should probably be updated too

Also it would be nice to actually get query caching on queries to partitioned tables.

How to repeat:
Assume your query cache will still work after porting to partitions.
[6 Jun 2012 19:02] Sveta Smirnova
Thank you for the report.

Bug #53775 has been fixed. Which exact version do you use?
[6 Jun 2012 19:11] Todd Wade
> Bug #53775 has been fixed.

I wouldn't call it 'fixed' The query cache was disabled. I'm unable to use the query cache as it is documented.

It should be stated prominently on the partitioning limitations page (http://dev.mysql.com/doc/refman/5.6/en/partitioning-limitations.html) that you can not use the query cache with a partitioned table.
[6 Jun 2012 19:23] Sveta Smirnova
Thank you for the feedback.

I was confused by comment:

----<q>----
[8 Jul 2010 12:59] Mikael Ronstrom

Disabling the query cache for partitioned tables
is a bit too harsh of a solution.
----</q>----

But after checking actual patch found you are correct. This must be documented, of course.
[8 Jul 2012 0:55] Kolbe Kegel
A documentation bug, verified for a month, not set to Server: Documentation, not assigned?
[8 Jul 2012 15:02] Valeriy Kravchuk
Kolbe,

I've fixed category now and added all versions actually affected. 

The bug was already copied to Oracle's internal BugDB few days ago and assigned to docs. team.
[11 Jul 2012 17:11] Jon Stephens
Duplicate of BUG#53775.
[12 Jul 2012 2:03] Todd Wade
[11 Jul 17:11] Jon Stephens
> Duplicate of BUG#53775.

Hi Jon,

I wouldn't call this bug a duplicate of 53775. In 53775, the query cache was disabled for partitioned tables. So be it.

This bug that I've filed is a documentation bug. This should be pretty clear by reading my original submission:

> I think this is a huge limitation and should be listed at http://dev.mysql.com/doc/refman/5.6/en/partitioning-limitations.html
>
> http://dev.mysql.com/doc/refman/5.5/en/query-cache-operation.html should probably be updated too

Thank you,
[12 Jul 2012 7:48] Jon Stephens
Todd,

The issue lay in the fact that the original bug report was not documented/closed correctly. If you view BUG#53775, you can see that this has been taken care of. 

There is no new *issue* here; thus, opening a new bug report is simply multiplying bug reports (and their attendant overhead) without need.