Bug #6543 Problems detected using this release
Submitted: 10 Nov 2004 10:35 Modified: 9 Oct 2005 11:15
Reporter: Juan Carlos Díaz Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:3.5.10 OS:Microsoft Windows (Windows 2000 sp4)
Assigned to: CPU Architecture:Any

[10 Nov 2004 10:35] Juan Carlos Díaz
Description:
I confirm this, after upgrading to 3.51.10, we have detected the
following problems so far:

1) With prior versions of MyODBC, we were able to create a DSN Data
Source without specifying user password or database name (these
parameters were set when creating the string for the adodb
connection).  This is no longer possible (i.e. the connection cannot
be established from adodb), now all the parameters must be specified
when creating the DSN Data Source (ODBC Data Source Administrator). 
We used this to create a system DSN on each machine, now we are forced
to create a user DSN for each user account (and trust me, it is a
nightmare).

2) MS-Access 2000 linked tables to some databases can no longer be
opened from.

3) A RUNDLL error occurs when closing the ODBC Data Source
Administrator ("shell32.dll,Control_RunDLL
c:\win\system32\odbccp32.cpl") (Win 2K sp

How to repeat:
1) Create a DSN Data Source without specifying user or database name and then try to use the data source from ADODB to establish a connection.

2) Don't know.  This consistently happens with some databases (always the same) and never with some other ones.

3) Open the ODBC Data Source, open any MyODBC data source, close the dialog and then close the ODBC Data Source window.
[3 Dec 2004 16:12] Minombre MisApellidos
I had exactly the same problem when updating to 3.5.10.
A possible "solution" to this might be:
  1.- Create a new System DNS with all parameters specified. 
  2.- After the creation, edit the System DNS Properties from the ODBC Origins Administrator and delete the entry/ies you don't want to be specified.

The System DNS will still be there!!!

Hope this helps.

   ThEmObBeR

(Como supongo que eres español por el nombre te lo pongo aquí en español, que no ando muy suelto en inglés...)

  1.- Crea un nuevo origen de datos de Sistema con el administrador de orígenes de Datos ODBC con todos los campos necesarios para su creación.
  2.- Edita el origen de datos ya creado (Botón configurar), eliminando los que no quieres que estén ahí.

El DNS del sistema seguirá ahí aún habiendo quitado esos campos...

Espero que sea de ayuda.
  ThEmObBeR
[8 Feb 2005 14:41] Dana Marek
After upgrading to My ODBC connector 3.51.10, I tried to link tables, from Access 2000 SR-1, to MySQL 4.9, (I think).  The Microsoft Error, that I received:
  "ODBC--call failed
   [MySQL][ODBC 3.51 Driver] Could not determine the driver name
   could not lookup setup library. (#0)."

  I am also using Windows 2000 sp4.

  I noticed that using the Uninstall option, from the setup, does not remove the myodbc3 .dll and .lib files from the c:\winnt\system32 directory.  Do you think the 3.51.06 unistall was not complete and there are other files that were not removed?
[26 Jul 2005 13:47] Ivano Luberti
The "Could not determine the driver name so could not lookup setup library error
happens also in Windows XP Pro SP2 using Office 2003 and trying to create the DSN from Microsoft Query , the software used in Excel to build external data link
[6 Oct 2005 21:44] Mark Matthews
Please reverify w/ 3.51.12 as there are fixes in there that most likely address this bug.
[9 Oct 2005 11:15] Vasily Kishkin
I reverified the bug on 3.51.12. It looks like the bug was fixed.
[24 Oct 2005 5:29] Juan Carlos Díaz
I confirm that the problem is not longer present in version 3.51.12 (at least under Windows XP)
[6 Apr 2007 20:32] Dana Marek
I am sorry I had not gotten back to you on this.  I was laid off from my job shortly after I found a solution to this problem and forgot all about this.  The solution, using Windows 2000, is to download the newest Microsoft Data Access Component, from Mircrosoft, I think the latest is MDAC_TYP.EXE.  This modification was added into windows XP in one of the service packs.  This modification is also required if you are planning to access a MySQL database using Visual Basic 6 code.