Bug #65407 InnoDB: Assertion failure in thread 1872 in file rem0rec.c line 561
Submitted: 24 May 2012 4:37 Modified: 30 Jan 2013 19:14
Reporter: ovidiu craciun Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S1 (Critical)
Version:5.5.24 OS:Microsoft Windows (Server 2008 R2 Standard)
Assigned to: CPU Architecture:Any
Tags: innodb crash rem0rec assertion

[24 May 2012 4:37] ovidiu craciun
Description:
our mysql is crashing and it's bringing down the OS as well. I can provide windows crash dump file as well. 

windows: server 2008 r2 standard; 64bit; 8Gb ram; 
mysql: 5.5.24 -- the latest we could found available
db size: we have only one db which is about 8Gb in size

I can provide any other info if needed

-------------------------------------------------------------------------------
mysql error log
-------------------------------------------------------------------------------
120523 19:33:39  InnoDB: Waiting for the background threads to start
120523 19:33:40 InnoDB: 1.1.8 started; log sequence number 18278812914
120523 19:33:41 [Note] Server hostname (bind-address): '(null)'; port: 3306
120523 19:33:41 [Note]   - '(null)' resolves to '::';
120523 19:33:41 [Note]   - '(null)' resolves to '0.0.0.0';
120523 19:33:41 [Note] Server socket created on IP: '0.0.0.0'.
120523 19:33:48 [Note] Event Scheduler: Loaded 0 events
120523 19:33:48 [Note] C:\mysql\bin\mysqld: ready for connections.
Version: '5.5.24'  socket: ''  port: 3306  MySQL Community Server (GPL)
120523 22:25:09  InnoDB: Assertion failure in thread 1872 in file rem0rec.c line 561
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
InnoDB: Thread 2728 stopped in file os0sync.c line 781
InnoDB: Thread 1972 stopped in file os0sync.c line 781
InnoDB: Thread 2444 stopped in file fil0fil.c line 4702
InnoDB: Thread 2624 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 824 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2932 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2312 stopped in file ha_innodb.cc line 7723
InnoDB: Thread 1840 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2632 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 1984 stopped in file ut0ut.c line 76
InnoDB: Thread 2628 stopped in file ha_innodb.cc line 7723
InnoDB: Thread 2696 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 1968 stopped in file os0sync.c line 474
InnoDB: Thread 2976 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 1592 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2648 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2136 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 548 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2752 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2812 stopped in file ha_innodb.cc line 7723
InnoDB: Thread 2856 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2644 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 652 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2028 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 812 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2680 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 1700 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 1172 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 1372 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2348 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 1908 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2852 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2520 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2352 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2636 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2236 stopped in file ha_innodb.cc line 6039
InnoDB: Thread 2816 stopped in file sync0rw.c line 572
InnoDB: Thread 1168 stopped in file sync0arr.c line 359
InnoDB: Thread 2652 stopped in file sync0arr.c line 359
InnoDB: Thread 2504 stopped in file sync0arr.c line 359
InnoDB: Thread 1432 stopped in file sync0arr.c line 359
InnoDB: Thread 2476 stopped in file sync0arr.c line 359
InnoDB: Thread 2748 stopped in file sync0arr.c line 359
InnoDB: Thread 2340 stopped in file sync0arr.c line 359
InnoDB: Thread 2364 stopped in file sync0arr.c line 359
InnoDB: Thread 1976 stopped in file os0sync.c line 474

-------------------------------------------------------------------------------

-------------------------------------------------------------------------------
windows crash info
      the file "C:\Users\Administrator\AppData\Local\Temp\2\WER-32049703-0.sysdata.xml" mentioned in the log was not found on the server though; only the dmp file.
-------------------------------------------------------------------------------
Problem signature:
  Problem Event Name:	BlueScreen
  OS Version:	6.1.7601.2.1.0.272.7
  Locale ID:	2057

Additional information about the problem:
  BCCode:	1a
  BCP1:	0000000000005003
  BCP2:	FFFFF70001080000
  BCP3:	000000000000EE98
  BCP4:	00000001810DD009
  OS Version:	6_1_7601
  Service Pack:	1_0
  Product:	272_3

Files that help describe the problem:
  C:\Windows\Minidump\052312-16468-01.dmp
  C:\Users\Administrator\AppData\Local\Temp\2\WER-32049703-0.sysdata.xml

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

--------------------------------------------------------------------------------

How to repeat:
it is not reproduce-able 
only to our server

Suggested fix:
n/a
[24 May 2012 5:01] MySQL Verification Team
Hi!  Please compress the file C:\Windows\Minidump\052312-16468-01.dmp and upload it for us to inspect.  

I should however note that if you're getting a BSOD, then you probably have a hardware, driver, or OS problem that is likely not caused by mysqld.
[24 May 2012 5:08] ovidiu craciun
windows crush dump

Attachment: 052312-16468-01.rar (application/octet-stream, text), 16.91 KiB.

[24 May 2012 6:27] Valeriy Kravchuk
Please, upload also the entire error log.
[24 May 2012 6:29] MySQL Verification Team
The minidump is a kernel minidump.

BUGCHECK_STR:  0x1a_5003
DEFAULT_BUCKET_ID:  DRIVER_FAULT_SERVER_MINIDUMP
PROCESS_NAME:  w3wp.exe
MODULE_NAME: nt
IMAGE_NAME:  ntkrnlmp.exe

The OS crash is not related to mysqld. w3wp.exe is an IIS component!
[24 May 2012 6:32] ovidiu craciun
Full error log

Attachment: mySQL-ThirdCrash-IS-15929.rar (application/octet-stream, text), 20.20 KiB.

[30 Jan 2013 19:14] Sveta Smirnova
Thank you for the log file.

Log file also confirms MySQL server crashed, because OS crashed:

120523 12:03:46 [Note] C:\mysql\bin\mysqld: ready for connections.
Version: '5.5.24'  socket: ''  port: 3306  MySQL Community Server (GPL)

This is server startup at 12:03

120523 19:31:51 [Note] Plugin 'FEDERATED' is disabled.
120523 19:31:52 InnoDB: The InnoDB memory heap is disabled
120523 19:31:52 InnoDB: Mutexes and rw_locks use Windows interlocked functions
120523 19:31:52 InnoDB: Compressed tables use zlib 1.2.3
120523 19:31:53 InnoDB: Initializing buffer pool, size = 107.0M
120523 19:31:53 InnoDB: Completed initialization of buffer pool
120523 19:31:53 InnoDB: highest supported file format is Barracuda.
InnoDB: Log scan progressed past the checkpoint lsn 18266867184
120523 19:31:53  InnoDB: Database was not shut down normally!

This is another startup at 19:31

There is no "normal shutdown" in between.

This is not MySQL bug.