Bug #65174 Workbench hangs when clicking to delete an EER Diagram
Submitted: 2 May 2012 8:24 Modified: 18 Jul 2012 19:06
Reporter: Jacopo Salvestrini Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench: Modeling Severity:S1 (Critical)
Version:5.2.38 rev8753 OS:Linux (Ubuntu 12.04)
Assigned to: CPU Architecture:Any
Tags: diagram, hang, workbench

[2 May 2012 8:24] Jacopo Salvestrini
When I attempt to delete a previously created EER diagram, by right-clicking on 'delete' on the diagram's icon, workbench hangs and I have to force quitting it.

How to repeat:
Create a new model, create a new diagram, and put a table in it (through diagram view).
Go back to model view and right-click to the diagram icon, select 'delete'.

Suggested fix:
I have no idea; tried to run workbench through the terminal, but had no output whatsoever.
[2 May 2012 20:24] MySQL Verification Team
Please try version 5.2.39. Thanks.
[3 May 2012 9:03] Jacopo Salvestrini

The mysql-workbench package I installed was from the Ubuntu (12.04) repositories:
mysql-workbench 5.2.38
and requires:
libmysqlclient18 (5.5.22, version installed)
mysql-workbench-data 5.2.38
libzip2 (0.10, version installed)

I then tried version 5.2.39 downloaded from MySQL website, which is for Ubuntu 11.10 and requires:
libmysqlclient16 (=>5.1.21)
libzip1 (=>0.8)
Those two packages are not available in Ubuntu 12.04 (the version I am using) rep. but in Ubuntu 11.10's. It is curious to see how the version of the dependencies seems to be correct in Ubuntu 12.04 packages, but it is not recognised because of the different name of the package (libzip1->libzip2, libmysqlclient16->libmysqlclient18); I guess this is the choice of who maintains the packages.

Now, with version 5.2.39, this bug is disappeared, but there is another one, that happens in the same way as described in this bug submission, except that instead of deleting the EER Diagram I simply close it (by clicking on the 'x' on the corner of the diagram-view tab) and then I try to close the model view (by clicking in the same way as before); then the program hangs. So I suppose that in the new version the bug is only superficially solved, but there is still some bug that relates with these two.

May also be interesting to note that this is the first time that mysql-workbench package is found in the Ubuntu rep.

I hope this may help.
[8 May 2012 13:34] MySQL Verification Team
Thank you for the bug report.
[8 May 2012 14:47] Jacopo Salvestrini
you're welcome. I really like Workbench, so if there's anything more I can do, please just ask =)
[17 May 2012 11:32] Luigi Massa
the problem persist with mysql-workbench-gpl-5.2.40-1ubu1104-amd64.deb

[16 Jul 2012 17:06] Daniel Holsboer
I have the same bug in Fedora 17 with workbench 5.2.40
[18 Jul 2012 19:06] Philip Olson
This has been fixed as of the soon-to-be-released Workbench 5.2.41, and 
here's the changelog entry:

Deleting an EER diagram would cause Workbench to hang.