Bug #64987 Memory leak in mysql-5.6.6-labs-april-2012
Submitted: 15 Apr 2012 20:13 Modified: 18 May 2012 14:41
Reporter: Vadim TKACHENKO Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S3 (Non-critical)
Version:5.6.6 OS:Any
Assigned to: CPU Architecture:Any

[15 Apr 2012 20:13] Vadim TKACHENKO
Description:
I wanted to play with mysql-5.6-labs,
but loading big dataset it shows symptoms of memory leak and be killed by OOM.

I use sysbench command:

sysbench --test=tests/db/parallel_prepare.lua --oltp-table-size=100000000 --oltp-tables-count=8 --mysql-user=root --num-threads=8 --mysql-socket=/var/lib/mysql/mysql.sock run

I start mysqld as
bin/mysqld --defaults-file=/etc/my.56.cnf --datadir=/mnt/tachion/data/

my.cnf is

[mysqld]
gdb

datadir=/mnt/tachion/data
tmpdir=/mnt/tachion/data

#for SSD
#innodb_read_ahead = none
#innodb_flush_neighbor_pages = 0
#innodb_adaptive_flushing_method  = keep_average

#innodb_adaptive_hash_index_num = 16

#####fixed innodb options
innodb_file_per_table = true
innodb_data_file_path = ibdata1:10M:autoextend
innodb_flush_log_at_trx_commit = 1
innodb_flush_method = O_DIRECT
innodb_log_buffer_size = 256M

innodb_buffer_pool_size = 250G
#innodb_buffer_pool_size = 39G

innodb_log_file_size = 8G

#innodb_log_file_size = 1024M
#innodb_log_file_size = 256M
innodb_log_files_in_group = 2

#innodb_doublewrite = false

#####plugin options
innodb_read_io_threads = 8
innodb_write_io_threads = 16
innodb_io_capacity = 10000
innodb_max_io_capacity=10000
#innodb_buffer_pool_instances=8

#####new XtraDB specific for TPC-C
###innodb_page_size = 4K
#innodb_log_file_size = 4G

#not innodb options (fixed)

port = 3306
back_log = 50
max_connections = 400
max_connect_errors = 10
table_cache = 2048
max_allowed_packet = 16M
binlog_cache_size = 16M
max_heap_table_size = 64M
sort_buffer_size = 4M
join_buffer_size = 4M
thread_cache_size = 8
query_cache_type = 0
#default_table_type = InnoDB
thread_stack = 192K
tmp_table_size = 64M

#server-id = 10

#*** MyISAM Specific options
key_buffer_size = 8M
read_buffer_size = 1M
read_rnd_buffer_size = 4M
bulk_insert_buffer_size = 8M
myisam_sort_buffer_size = 8M
myisam_max_sort_file_size = 10G
#myisam_max_extra_sort_file_size = 10G
myisam_repair_threads = 1
myisam_recover

socket=/var/lib/mysql/mysql.sock
user=root
skip-grant-tables

[mysql]
no-auto-rehash
socket=/var/lib/mysql/mysql.sock

[client]
socket=/var/lib/mysql/mysql.sock

There are columns VSZ and RSS for mysqld process with 10 sec interval

http://pastebin.com/GL06RrKZ

When RSS reached memory limit on the box (380GB), mysqld is killed.

How to repeat:
see above
[17 Apr 2012 8:27] Shane Bester
See Bug 13960056 - MEMORY LEAK ON 5.6.6 - DBT2 / DBSTRESS
[18 May 2012 14:41] Valeriy Kravchuk
It's a duplicate of the verified internal bug that was reported few days earlier. Still not fixed at the moment.
[15 Aug 2014 20:09] Sveta Smirnova
Internal  bug reported as fixed.