Bug #64907 MySQL Workbench 5.2.38 install fails "MSVCR100.dll not found"
Submitted: 8 Apr 2012 3:52 Modified: 24 May 2012 10:57
Reporter: Brian Lawler Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL for Windows: Installer Severity:S2 (Serious)
Version:5.2.38 OS:Windows (Windows 7 Home)
Assigned to: CPU Architecture:Any
Tags: MySQL Workbench 5.2.38 install failure MSVCR100.dll not found

[8 Apr 2012 3:52] Brian Lawler
To see this bug, download the installation package for MySQL Workbench version 5.2.35 onto a machine running Windows 7 Home Edition and try to install.  Right before the installation completes, a DOS window appears along with a system error dialog box.

The DOS window has its title as the install directory for python.exe, and the error dialog box is titled "python.exe - System Error".  I have not seen this happen on previous versions of MySQL Workbench.

Specifically, the python.exe system error reads as follows:

"The program can't start because MSVCR100.dll is missing from your computer.  Try reinstalling the program to fix this problem."

Then the install wizard says the installation is complete, and the Workbench will crash at startup if you try to run it.

How to repeat:
Download the installation package for MySQL Workbench version 5.2.35 onto a machine running Windows 7 Home Edition and try to install.  Right before the installation completes, a DOS window appears along with a system error dialog box.

Suggested fix:
Make sure all the dll files are present in the install package MySQL Workbench and its other subsets.
[8 Apr 2012 3:54] Brian Lawler
Seems like the MSVCR100.dll is not included in the current install package for MySQL Workbench version 5.2.38
[8 Apr 2012 7:29] Valeriy Kravchuk
Please, clarify what exact version is problematic, 5.2.35 or 5.2.38. Do you install Workbench from MySQL Installer or from standalone .msi?
[8 Apr 2012 8:49] Brian Lawler
To clarify, this is for version 5.2.38.  I didn't notice the typo on the version until after I submitted the bug report, and I haven't found any way of editing it.
[8 Apr 2012 10:05] Valeriy Kravchuk
OK, had you installed 5.2.38 from .msi installer or from .zip? Looks like VS2010 runtime is missing on your system. .msi installer should mention it as one of pre-requsites and even provide URL to download it from Microsoft.
[9 Apr 2012 2:16] Brian Lawler
I noticed that, however I wasn't able to find clear documentation as to which version of visual studio I needed.  To remedy that, I installed every version of visual studio I could find, and the installer for the workbench still gave the error - but it was able to run.
[9 Apr 2012 5:51] Valeriy Kravchuk
This is what you probably need:


Please, check if you still get the same error after installing it.
[10 May 2012 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[13 May 2012 8:56] Mariusz Piotrowski
Proposed solution works on Windows 7 x64.
Thank you
[13 May 2012 9:21] Valeriy Kravchuk

Was the problem entirely solved in your case after installing missing VS2010 runtime? Please, confirm.
[22 May 2012 18:48] Dmitriy Broytman
Because Workbench is a 32bit application, it isn't working with the 64bit version of Visual Studio 2010 redistributable package. Install the 32bit version of Visual Studio 2010 redistributable and repair the workbench installation. 

Worked for me!
[24 May 2012 10:57] Valeriy Kravchuk
So, this problem was not a result of any bug in MySQL Workbench code.
[3 Aug 2012 13:41] Marc Bauer
This bug still exists in 5.2.41. The bug is in the setup that does not detect that the x86 version of the C++ 2010 is missing and you have installed the x64. Setup need to detect this and warn that the x86 version is missing.

Today it does not warn about the failed requirements after you have installed the x64 version only.
[19 Nov 2012 8:02] Alan Wilder
I had same problem.

I've solved with the solution that mentions Valeriy Kravchuk.

I have Windows 7 (64)


[4 Dec 2012 0:48] Dave Browning
Simple fix:-

Install the Pre-Reqs..

Issue FIXED!
[15 Dec 2013 12:46] Jorge Ribeiro
This problem happened to me.
Your Windows 7 is x64, right?

MySQL Workbench needs Microsoft Visual C++ 2010 Redistributable Package, but you need to install the x86 version, and not the x64 version. The x64 version doesn't work with MySQL Workbench because it is x86.
[10 Oct 2014 9:13] Burçak Otlu

I was installing MySQL 5.6.21 on my laptop with windows 8 (x64) OS.
However I couldn't install MySQL workbench 6.2.3 since

1: This application requires the Visual C++ Redistributable Package for Visual Studio 2013. Please install the redistributable package and then run this installer again. See the online documentation for more details.

Although I have downloaded and installed x86 version of  Visual C++ Redistributable Package for Visual Studio 2013 from

It still gives the same error message.

Any help?
[14 Dec 2014 21:01] José Filipe Neis
Hey Burçak,

I was installing Workbench CE 6.2.3 in the same enviroment (Win8 x64) and even after I solved the problem after installing the x64 version of Visual C++ Redistributables.

I believe that if you downloaded (as I did) the Workbench x64 installer, that´s the version it will need, as it even installs itself in the x64 folder by default (Program Files) instead of Program Files x86.