Bug #64899 mysql_install_db fails with sql-mode NO_BACKSLASH_ESCAPES
Submitted: 7 Apr 2012 15:40 Modified: 10 Apr 2012 16:44
Reporter: Jon Dufresne Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: General Severity:S3 (Non-critical)
Version:5.5.21 OS:Linux
Assigned to: CPU Architecture:Any

[7 Apr 2012 15:40] Jon Dufresne
Description:
Description of problem:
In /etc/my.cnf set sql-mode to NO_BACKSLASH_ESCAPES:

sql-mode=NO_BACKSLASH_ESCAPES

Once set, run mysql_install_db. Some SQL fails, but the install continues.

# mysql_install_db 
Installing MySQL system tables...
OK
Filling help tables...
ERROR: 1064  You have an error in your SQL syntax; check the manual that
corresponds to your MySQL server version for the right syntax to use near
'abc\'), UNHEX(HEX(\'abc\'));\n        -> \'abc\', 616263, \'abc\'\nmysql>
SELECT' at line 1
120407  3:57:42 [ERROR] Aborting

120407  3:57:42 [Note] /usr/libexec/mysqld: Shutdown complete

...

How to repeat:
* Set sql-mode=NO_BACKSLASH_ESCAPES in /etc/my.cnf
* Run mysql_install_db
[10 Apr 2012 16:44] Sveta Smirnova
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Use option --no-defaults when run mysql_install_db