Bug #6487 TEXT columns containing char codes > 0x7F are not displayed
Submitted: 7 Nov 2004 22:04 Modified: 9 Dec 2004 14:21
Reporter: Malcolm Holloway Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Query Browser Severity:S2 (Serious)
Version:1.1.0 gamma OS:Microsoft Windows (Windows XP)
Assigned to: Assigned Account CPU Architecture:Any

[7 Nov 2004 22:04] Malcolm Holloway
Description:
Data in columns of type TEXT is not displayed if the string contains characters with codes >0x7F although the text is correctly inserted into the table. This applies to the Result Area and the Popup Editor. Columns of type VARCHAR that contain exactly the same characters are displayed as expected.

Changing charset has no apparent effect. Behaviour is similar for all charsets.

How to repeat:
Create a database with a VARCHAR column and a TEXT column. Enter "áéíóú" into each column and save. Close MySQL Browser. Reopen MySQL Browser and display the new table. The VARCHAR data is visible but the TEXT data is hidden and not editable.
[8 Nov 2004 14:08] Michael G. Zinner
Same content of TEXT and VARCHAR field

Attachment: bug6487.png (image/png, text), 62.03 KiB.

[8 Nov 2004 14:10] Michael G. Zinner
Could you state the character set you are using for your database and the table? 

I tried to replicate the problem here but did not succeed (see screenshot). 

If possible, please try to explicitly change the character set of the columns to UTF8 or latin1 and test again. 

Thanks!
[8 Nov 2004 21:52] Malcolm Holloway
OK - I think I may have found the reason - I'm running mysql 4.0.21-nt on my development machine and that's the version on the webserver too.

When I upgraded my development machine to 4.1.7 all the text became visible - problem solved - sort of. Upgrading the webserver is not a process that will happen quickly. The question now becomes:

Is MySQL Query Browser designed for use only with mysql 4.1 or higher? I can't find any sytem requirements anywhere and I have had no warnings about this issue.
[9 Nov 2004 14:21] Malcolm Holloway
Using MySQL 4.0.21 - text fields are inconsistently displayed.

Export as CSV file handles text fields with characters >0x7f incorrectly
Export as HTML file handles text fields with characters >0x7f incorrectly
Export as XML file handles text fields with characters >0x7f incorrectly
Export as Excel file handles text fields with characters >0x7f incorrectly

Example files sent
[9 Nov 2004 14:23] Malcolm Holloway
csv file: id=1,text=áéíóú,varchar=áéíóú

Attachment: testa.csv (application/octet-stream, text), 55 bytes.

[9 Nov 2004 14:23] Malcolm Holloway
dtd file: id=1,text=áéíóú,varchar=áéíóú

Attachment: testa.dtd (application/octet-stream, text), 163 bytes.

[9 Nov 2004 14:23] Malcolm Holloway
html file: id=1,text=áéíóú,varchar=áéíóú

Attachment: testa.html (text/html), 455 bytes.

[9 Nov 2004 14:24] Malcolm Holloway
xls file: id=1,text=áéíóú,varchar=áéíóú

Attachment: testa.xls (application/vnd.ms-excel, text), 836 bytes.

[9 Nov 2004 14:24] Malcolm Holloway
xml file: id=1,text=áéíóú,varchar=áéíóú

Attachment: testa.xml (text/xml), 213 bytes.

[9 Nov 2004 14:27] Malcolm Holloway
shows text field in editor: id=1,text=áéíóú,varchar=áéíóú

Attachment: testa.png (image/png, text), 92.21 KiB.

[14 Feb 2005 22:54] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".