Bug #64826 server doesnt start again after stopping
Submitted: 31 Mar 2012 18:46 Modified: 19 Dec 2012 20:25
Reporter: sherif youssef Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Config Wizard Severity:S1 (Critical)
Version:5.5 OS:Microsoft Windows (2008 r2)
Assigned to: CPU Architecture:Any

[31 Mar 2012 18:46] sherif youssef
Description:
whenever i install my MySQL server then start the service in windows, then stop it once, it wouldn't start again unless i remove/reinstall the entire package.
this is the log i get
ps: i am also unable to start the service via windows, it gives me error 1067: the process terminated unexpectedly.
thanks for the help
sherif
this is my log when i stop and try to start it again
 
2012-03-31 20:39:53 - Workbench will use cmd shell commands to start/stop this instance

2012-03-31 20:39:54 - Status check of service 'MySQL55' returned running

2012-03-31 20:39:55 - Status check of service 'MySQL55' returned running

2012-03-31 20:39:57 - Status check of service 'MySQL55' returned running

2012-03-31 20:39:57 - Server stop done.

2012-03-31 20:39:57 - Status check of service 'MySQL55' returned stop pending

FROM C:\ProgramData\MySQL\MySQL Server 5.5\data\WIN-45TLLE9BHGJ.err:

    120331 20:39:57  [Note] C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld: Normal shutdown

    120331 20:39:57  [Note] Event Scheduler: Purging the queue. 0 events

2012-03-31 20:40:01 - Checking service status of instance MySQL55...

2012-03-31 20:40:01 - Status check of service 'MySQL55' returned stopped

2012-03-31 20:40:02 - Checking service status of instance MySQL55...

2012-03-31 20:40:02 - Status check of service 'MySQL55' returned stopped

2012-03-31 20:40:03 - Status check of service 'MySQL55' returned stopped

2012-03-31 20:40:03 - Starting server...

2012-03-31 20:40:03 - Status check of service 'MySQL55' returned stopped

2012-03-31 20:40:04 - Server start done.

2012-03-31 20:40:04 - Status check of service 'MySQL55' returned start pending

FROM C:\ProgramData\MySQL\MySQL Server 5.5\data\WIN-45TLLE9BHGJ.err:

    120331 20:40:03  [Note] Plugin 'FEDERATED' is disabled.
    120331 20:40:03  InnoDB: The InnoDB memory heap is disabled
    120331 20:40:03  InnoDB: Mutexes and rw_locks use Windows interlocked functions
    120331 20:40:03  InnoDB: Compressed tables use zlib 1.2.3
    120331 20:40:03  InnoDB: Initializing buffer pool, size = 906.0M
    120331 20:40:03  InnoDB: Completed initialization of buffer pool

InnoDB: Error: log file .\ib_logfile0 is of different size 0 493879296 bytes

InnoDB: than specified in the .cnf file 0 475004928 bytes!
    120331 20:40:04  [ERROR] Plugin 'InnoDB' init function returned error.
    120331 20:40:04  [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
    120331 20:40:04  [ERROR] Unknown/unsupported storage engine: INNODB
    120331 20:40:04  [ERROR] Aborting
    120331 20:40:04  [Note] C:\Program Files\MySQL\MySQL Server 5.5\bin\mysqld: Shutdown complete
2012-03-31 20:40:05 - Checking service status of instance MySQL55...

2012-03-31 20:40:05 - Status check of service 'MySQL55' returned start pending

2012-03-31 20:40:09 - Checking service status of instance MySQL55...

2012-03-31 20:40:09 - Status check of service 'MySQL55' returned stopped

How to repeat:
simply by stopping the service after a fresh installation

Suggested fix:
re-installation but its not a real fix.
[31 Mar 2012 20:27] sherif youssef
i have found the solution to this problem:
removed all the components and reinstalled in a different directory than program files,
which caused the problem earlier having c:/program files and c:/program files(x86)
thanks
sherif
[1 Apr 2012 7:41] Valeriy Kravchuk
Please, send the entire error log, C:\ProgramData\MySQL\MySQL Server 5.5\data\WIN-45TLLE9BHGJ.err
[2 May 2012 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[4 Oct 2012 7:43] Marko Mäkelä
The log file size problem is Bug#13494.
[4 Dec 2012 10:26] Charles Bird
I having the same issue:
1. Started with mysql-installer-community-5.5.28.3 and choose not to start the server with windows by default. Was unable to start it up manually from MySQL Workbench. Results the same as for 'sherif'.
2. Removed, tried again, failed.
3. Installed mysql-5.5.28-win32.msi with mysql-workbench-gpl-5.2.44-win32.msi and carefully made sure I didn't alter any settings. Worked fine...
4. ...until I stopped the server. Now I'm unable to start it again, see below.

* Using Windows 7 Home Premium (SP1) x64. MySQL install path: "C:\Program Files (x86)\MySQL"
* Cannot find any error logs.
* Startup Message Log (MySQL Workbench 5.2 CE):
2012-12-04 11:01:57 - Workbench will use cmd shell commands to start/stop this instance
2012-12-04 11:01:57 - Status check of service 'MySQL5' returned stopped
2012-12-04 11:01:57 - Status check of service 'MySQL5' returned stopped
2012-12-04 11:01:58 - Status check of service 'MySQL5' returned stopped
2012-12-04 11:01:58 - Starting server...
2012-12-04 11:02:00 - Status check of service 'MySQL5' returned stopped
2012-12-04 11:02:00 - Server start done.
2012-12-04 11:02:00 - Status check of service 'MySQL5' returned start pending
2012-12-04 11:02:05 - Checking service status of instance MySQL5...
2012-12-04 11:02:05 - Status check of service 'MySQL5' returned start pending
2012-12-04 11:02:07 - Checking service status of instance MySQL5...
2012-12-04 11:02:07 - Status check of service 'MySQL5' returned stopped

Please let me know what else is needed to trace this.
[19 Dec 2012 20:25] Sveta Smirnova
Thank you for the feedback.

You should check MySQL error log file and adjust options accordingly. This is either not a bug or duplicate of bug which Marko mentioned.