Bug #64493 double clicking table name should add select query to query window
Submitted: 29 Feb 2012 17:29 Modified: 21 Aug 2014 20:42
Reporter: Alan Witkowski Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S4 (Feature request)
Version:5.2.38 rev 8753 OS:Any
Assigned to: CPU Architecture:Any
Tags: regression, UI, usability
Triage: Needs Triage: D5 (Feature request)

[29 Feb 2012 17:29] Alan Witkowski
Description:
Right now it just appends the table name to the query window (which isn't very useful). It should behave like the MySQL Query Browser program. e.g.

SELECT * FROM tablename LIMIT 0,1000;

instead of

tablename

How to repeat:
Double click any table name for any schema
[29 Feb 2012 18:12] Valeriy Kravchuk
Thank you for the feature request.
[29 Feb 2012 22:36] Alfredo Kojima
Adding the table name is the intended current implementation of double-click. 
Creating a SELECT query is done through other means.
[21 Aug 2014 20:42] Philip Olson
Fixed as of the MySQL Workbench 6.2.0 release, and here's the changelog entry:

The schema navigator now includes new overlay icons for common operations
such as table data view, table edit, and table/schema inspector.

Thank you for the bug report.