Bug #64481 checked line with error
Submitted: 28 Feb 2012 11:25 Modified: 20 Mar 2018 21:23
Reporter: maison sakamoto Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:6.3.3.0 build 592 OS:Microsoft Windows (Microsoft Windows 7 Service Pack 1 (build 7601), 32-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter
Triage: Triaged: D4 (Minor)

[28 Feb 2012 11:25] maison sakamoto
Description:
when I type something wrong, an "x" appears in place of the number of line ok.
Then solve the problem, but the "x" is still checked.

How to repeat:
exemple with error:
select 
   t sum(2+2) as sum;

exemple correct:
select 
   sum(2+2) as sum; /*her the "x" still here*/
[28 Feb 2012 11:34] maison sakamoto
Image example

Attachment: image example.png (image/png, text), 99.55 KiB.

[28 Feb 2012 11:45] Miguel Solorzano
Thank you for the bug report.
[27 Jul 2012 8:00] Philip Olson
Fixed as of Workbench 5.2.41, and here's the changelog entry:

Inputting invalid SQL would remain designated as such, even
after the SQL was corrected.
[24 Nov 2014 11:51] maison sakamoto
the same error is present in this latest version. Registered as serious as it is a repeat offender
[24 Nov 2014 11:54] maison sakamoto
How to repeat:
select * 
fsadf from tab_carta;

exemple correct:
select * 
from tab_carta; /*her the "x" still here*/
[24 Nov 2014 13:23] Mike Lischke
Posted by developer:
 
Reopening bug report as the error is well reproducible with the given example.
[24 Nov 2014 13:25] Mike Lischke
Not really a serious issue though. Just add a newline and the wrong marker is gone.
[24 Nov 2014 13:30] maison sakamoto
the error corrected back in new versions yes is serious.
[24 Nov 2014 13:45] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=74981 marked as duplicate of this one.
[18 Mar 2015 18:13] maison sakamoto
reported in 2012, is the third anniversary of this bug
[19 Mar 2015 8:23] Mike Lischke
I tried various ways to reproduce the problem again and failed. How do you edit the text so that the error marker remains? I typed the query with the syntax error (both with a newline between t and sum and also without). Then I removed t (both with forward delete as well as backward delete). In both cases the error marker disappears after a short moment.
[19 Mar 2015 11:31] maison sakamoto
sample of the error

Attachment: Desktop.rar (application/octet-stream, text), 221.05 KiB.

[19 Mar 2015 11:48] maison sakamoto
Little Mike Lischke, use the last example [24 Nov 2014 11:54] for reproduce the problem again, ask for help to another person making stage along with you if it is too difficult
[19 Mar 2015 12:40] maison sakamoto
I'm sorry sir Mike Lischke for my last post, I overreacted and was not friendly, I am grateful to have dedicated their time to this problem
[19 Mar 2015 13:09] Mike Lischke
You probably misunderstood me. What I was after was a way to reproduce the problem. A static image often doesn't represent the entire process to get to a certain result. Your new screenshot showed a slightly different scenario, which I could now use to reproduce the issue. The key here seems to be that the erroneous input must be at the beginning of the line. Anywhere else will properly update the error marker when the wrong text is removed.
[19 Mar 2015 13:20] maison sakamoto
video reproduction the bug

Attachment: Record_2015_03_19_10_18_27_659.rar (application/octet-stream, text), 286.16 KiB.

[5 May 2015 13:29] maison sakamoto
version correct
[5 May 2015 13:50] maison sakamoto
new version 6.3.3.0 build 592 yet
[26 Jul 2015 6:15] Paul Weiss
Works for me fine in version 6.3.4.0 on Microsoft Windows (7 Home Premium SP 1) 64-bit.
[27 Jul 2015 11:01] maison sakamoto
Paul Weiss, do this test https://bugs.mysql.com/file.php?id=22509&bug_id=64481 also no works in 6.3.4, it's a neglect not fix something as simple
[27 Jul 2015 11:14] maison sakamoto
new test in new version 6.3.4.0 build 828 ( 64bits )

Attachment: Sem título.png (image/png, text), 185.94 KiB.

[28 Jul 2015 22:29] Paul Weiss
Ah, yes. Following the steps in your video, I do have the same problem.
[20 Mar 2018 21:23] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.11 release, and here's the changelog entry:

Erroneous input at the beginning of the line in the SQL editor generated
an error marker that continued to display after the wrong input was
corrected or removed.

Thank you for the bug report.