Bug #6431 Administrator consumes huge amounts of system resources
Submitted: 4 Nov 2004 13:36 Modified: 13 Jun 2005 8:29
Reporter: Patrick Questembert Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S2 (Serious)
Version:1.0.13 OS:Microsoft Windows (Windows XP)
Assigned to: Vladimir Kolesnikov CPU Architecture:Any

[4 Nov 2004 13:36] Patrick Questembert
Description:
Backing up a database of size 960MB (28 tables) or analysing that backup file seems to consume system resources - anything else running on that system crawls to almost standstill. System returns to normal after a few minutes, presumably after memory pages are returned to the pool.

I don't see anything unusual in terms of processes and their memory or CPU usage however.

In some cases, the drain on system resources is such that Administrator quits with a variety of errors - which I can document in separate bugs. 

For example: GLib-ERROR **: gmem.c:140: failed to allocate 4452 bytes. Aborting ..."

But I feel the performance degradation is so severe that there is no point looking at the explicit failure scenarios until this is cleared-up.

I am not ruling out that 

I have two page files, each the maximum size of 4GB. Note that initially, before setting the pagefiles to these sizes, Administrator caused the system to run out of virtual memory and try to increase the sizes of the page files.

MySQL Server is 4.1.5-gamma-nt, system has 1GB Ram, runs Windows XP with SP2

How to repeat:
I can't think of anything special in my setup or the database (described above). Exhaustion on system resources seems directly proportional to the amount I am backing up - if I select only a few tables, there is no problem.

Backup is defined as "Normal Backup", "Use selected schemata completely" is selected and output file options only have "Complete INSERTs" selected.

No MySQL application are running at the time of backup and restore (a couple have open connections, but are stopped).
[8 Nov 2004 21:55] Patrick Questembert
I have confirmed that the root of the problem is an exhaustion of physical memory: watching this number with the Windows Tak Manager shows physical memory decreasing as backup or restore progresses.

Note that the same problem occurs for either backup or restore.

It's interesting to note that my system's physical memory is 1GB, just about the size of my database. As I keep adding content to my database, I find that I am less and less likely to succeed in completing a backup successfully. Obviously MySQL Admin should not allocate non-paged memory for everything it processes (if that is indeed what it's doing).
[20 Apr 2005 17:57] [ name withheld ]
I still have this problem with version 1.0.19 when attempting to backup a db with image tables that have over a thousand MEDIUMBLOBs in them.  The problem again occures when my memory (2GB) is reached by Administrator (can see it in task manager).  This really is a show stopper for me.  It seems that this problem was reported almost 6 months ago, is there any progress being made?
[21 Apr 2005 6:52] Mike Lischke
I'm very sorry for the delay. Currently there are too many things waiting and our team is extremely busy. I try to schedule some time for bug fixing as soon as time permits.

Mike
[13 Jun 2005 8:29] Vladimir Kolesnikov
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html