Bug #64250 Crash if query has one table (with primary key) and column references table name
Submitted: 7 Feb 2012 14:54 Modified: 9 Feb 2012 20:00
Reporter: Bob Dankert Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.37 OS:Microsoft Windows (W7 64, XP 32-bit)
Assigned to: CPU Architecture:Any
Tags: crash, primary key, query, table

[7 Feb 2012 14:54] Bob Dankert
Description:
I have found that WorkBench crashes if I try to perform a SELECT where there is only one table, which contains a primary key, and the column definition includes the table name.  I have repeated this numerous times and found it to consistently crash.  If the table does not have a primary key, Workbench does not crash.

How to repeat:
Execute these two statements in workbench, and it will crash on the SELECT query:

1.  create table test_table (id integer primary key auto_increment, field_1 varchar(10));

2.  select test_table.* from test_table;

Suggested fix:
Do not crash, execute query as normal
[7 Feb 2012 15:05] Peter Laursen
It crashes for me on the create statement. Also using W7/64

Attachment: stop.jpg (image/jpeg, text), 61.78 KiB.

[7 Feb 2012 15:09] Peter Laursen
I may be wrong about where it crashes.  The table was created before crash actually.
[7 Feb 2012 15:20] Bob Dankert
Executing the two statements one at a time, the CREATE executes normally, and WB crashes immediately on the SELECT.  

Glad to see it's not just my computer having the problem, thanks for confirming the bug.
[7 Feb 2012 17:56] Valeriy Kravchuk
Thank you for the bug report. Verified on 32-bit Windows XP also. No crash on Mac OS X.
[7 Feb 2012 20:28] Valeriy Kravchuk
Bug #64253 was marked as a duplicate of this one.
[8 Feb 2012 15:08] Valeriy Kravchuk
Bug #64262 was marked as a duplicate of this one.
[9 Feb 2012 20:00] Juan Rene Ramirez Monarrez
This is a dupicate of bug #63940, resolved in 5.2.38