Bug #63873 Open Value in Viewer does not show the text right away
Submitted: 29 Dec 2011 14:51 Modified: 9 Feb 2012 21:08
Reporter: Bob Dankert Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.37 OS:Microsoft Windows (W7 64)
Assigned to: CPU Architecture:Any
Tags: missing text, open value in viewer

[29 Dec 2011 14:51] Bob Dankert
Description:
It is happening on a particular query that opening the value viewer is not showing the text of the field I am trying to view when it initially pops up.  The Data length shows the correct length, and if I click on the Binary tab and then back on the Text tab, the text will then show up.  This is happening consistently on the query I am executing.

How to repeat:
I am able to make this happen consistently with the following:

1.  Execute a query like this on a table containing a column of type text:
select replace(`text_column`, 'value', '') as fieldname from `table_name`
2.  Right click on one of the fields, select 'Open in viewer'
3.  The text will be blank, the data length will show the correct length
4.  Clicking the binary tab, then the text tab again will show the text

Suggested fix:
Properly load the text when loading the viewer
[29 Dec 2011 14:53] Bob Dankert
I'm not sure how to attach a screenshot showing the issue, but I have one if needed.
[29 Dec 2011 15:21] MySQL Verification Team
To attach a file use the Files tab. Thanks.
[29 Dec 2011 15:24] Bob Dankert
Screenshot showing the issue

Attachment: Empty Text.JPG (image/jpeg, text), 28.80 KiB.

[29 Dec 2011 15:32] Valeriy Kravchuk
I can not repeat this with 5.2.37 on Mac OS X while working with MySQL server 5.5.20. What exact server version are you working with?
[29 Dec 2011 15:37] Bob Dankert
Here's the output of "select version();":  5.1.56-log

I just noticed that anytime I use the "Open value in viewer" function, it does not display the text properly, even for something as simple as "select 'text';".  Restarting WB did not make any difference.  I will restart my computer to see if that makes any difference.
[29 Dec 2011 15:45] Bob Dankert
Even after a full system reboot, the issue is still happening.  I am using "select 'test';" as my test query.  Please let me know what data I can provide for debugging purposes.  I'm guessing clearing out all of the program data files will fix the issue, but it will also cause me to lose over 100 saved connections, which will take hours to get re-entered.
[30 Dec 2011 7:39] Valeriy Kravchuk
Verified just as described on Windows XP. Looks like platform-specific bug.
[9 Feb 2012 21:08] Philip Olson
Fixed as of 5.2.38:

On Microsoft Windows, the "Open in viewer" menu
could be blank while viewing results.