Bug #63872 Alter table error at first "int" type field.
Submitted: 29 Dec 2011 13:22 Modified: 31 May 2018 17:14
Reporter: Tuncay KINALI Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.36, 5.2.37, 5.2.38 OS:Linux (Ubuntu 11.10)
Assigned to: CPU Architecture:Any

[29 Dec 2011 13:22] Tuncay KINALI
First of all, i'm sorry for my bad English.

I can't edit my any tables. When i right click of my any table and select "Alter Table", it says "There was an error parsing the DDL retrieved from the DBMS."

When i click "View DDL" result is:

"delimiter $$

CREATE TABLE `tblfinalistler` (
  `fldID` int(10) unsigned NOT NULL AUTO_INCREMENT,
  `fldIsim` varchar(45) DEFAULT NULL,
  `fldToplamOy` int(10) unsigned DEFAULT NULL,
  PRIMARY KEY (`fldID`),
  KEY `OY` (`fldToplamOy`)

The error line:
"`fldID` int(10) unsigned NOT NULL AUTO_INCREMENT,"

I try two different server but results are same.

My Local Server: mysql  Ver 14.14 Distrib 5.1.58, for debian-linux-gnu (x86_64) using readline 6.2

Production Server: mysql  Ver 14.12 Distrib 5.0.92, for unknown-linux-gnu (x86_64) using readline 5.1

My system info:
MySQL Workbench CE for Linux/Unix version 5.2.36  revision 8542
Configuration Directory: /home/tuncay/.mysql/workbench
Data Directory: /usr/share/mysql-workbench
Cairo Version: 1.10.2
Rendering Mode: OpenGL is not available on this system, so Native is used for rendering.
OS: Linux 3.0.0-14-generic
CPU: 8x Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz 800.000 MHz, 7,7 GB RAM

How to repeat:
When i want to alter any table.

Suggested fix:
I have no idea.
[29 Dec 2011 14:18] Valeriy Kravchuk
Please, check with a newer version, 5.2.37. I do not see any problem with your table on MySQL server 5.5.20 with this version of Workbench.
[29 Dec 2011 15:00] Tuncay KINALI
When i check for update it says "You are already using the latest version of MySQL Workbench." but i found 5.2.37 rev 8576 in mysql website. I installed this version too but didn't change anything, continues same error.
[29 Dec 2011 21:28] MySQL Verification Team
I couldn't repeat on Ubuntu 11.04 (VirtualBox).
[30 Dec 2011 0:02] Tuncay KINALI
I apologize for giving wrong information. I am using Ubuntu 11.10 x64.

When I edit table data with MySQL Query Browser and change field type from "int" to "bigint" and retry alter with workbench, then it works but datatype filed shows only "(20)"

Please look at http://imageshack.us/photo/my-images/546/seim002.png/
[3 Jan 2012 19:07] Armando Lopez Valencia
Hello Kinali.
Would you mind send us a dump of a DB where you can reproduce this problem?
[3 Jan 2012 20:51] Tuncay KINALI
Sample DB dump

Attachment: krombera_mytalentfinal_tblfinalistler.sql (text/x-sql), 3.96 KiB.

[20 Jan 2012 2:20] Alfredo Kojima
Does that happen with any int column?
Can you try creating the following 2 tables and see if both are not editable?
CREATE TABLE signed ( col int );
CREATE TABLE unsigned ( col int unsigned );
[22 Jan 2012 16:04] Tuncay KINALI
Hi Alfredo,

Both table aren't editable.
[23 Feb 2012 21:05] MySQL Verification Team
Please try version 5.2.38. Thanks.
[24 Feb 2012 7:41] Tuncay KINALI
Hi Miguel,

I tried last version but results are same. Nothing changed. I can't edit any table.
[9 Mar 2012 17:26] Tuncay KINALI

Does not appear to be a problem when I run the application with the following command.

env LANG="en_US.UTF-8" /usr/bin/mysql-workbench

(I'm using Ubuntu with Turkish language pack)
[10 Mar 2012 9:02] Valeriy Kravchuk
Bug #64463 looks similar/related.
[14 Mar 2012 14:34] Alfredo Kojima
bug #64463 is a duplicate
[15 Mar 2012 4:07] Alfredo Kojima
To repeat the bug in Ubuntu, install language-pack-tr and set LANG=tr_TR.UTF-8 

There are likely problems in several places in both backend and different frontends, including the bug marked duplicate above.
[15 Nov 2014 12:07] Erman Müftüoğlu
Hi, do you plan any patch for this bug in your roadmap ?
[31 May 2018 17:14] Christine Cole
Posted by developer:
Fixed as of the upcoming MySQL Workbench 8.0.12 release, and here's the changelog entry:

The combination of Ubuntu with language-pack-tr and LANG=tr_TR.UTF-8
produced an error message when columns of type INT were parsed during
operations that altered existing tables.

Thank you for the bug report.