Bug #63746 MySQL crashes in dialogue "Synchronize Model with Database"
Submitted: 14 Dec 2011 10:47 Modified: 27 Jan 2012 2:55
Reporter: Lorenz Kahl Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench: Modeling Severity:S1 (Critical)
Version:5.2.36 OS:MacOS (10.7.2)
Assigned to: CPU Architecture:Any

[14 Dec 2011 10:47] Lorenz Kahl
After having succeeded to step "Fetch Object Info" clicking "Continue" will cause MWB to crash. 

How to repeat:
Not sure - it already worked with that database previously and now just stopped.
I'm willing to provide more specific info. Please let me know what you need.
[17 Dec 2011 14:51] Valeriy Kravchuk
What exact server version, 5.x.y, are you trying to synchronize with? Can you upload .mwb file that leads to crash?
[19 Dec 2011 8:41] Lorenz Kahl
The MySQL server is 5.1.44
[19 Dec 2011 8:44] Lorenz Kahl
I'm using MySQL locally using MAMP Pro 1.9
[20 Dec 2011 8:02] Valeriy Kravchuk
No crash on Windows XP while synchronizing with 5.1.58, just one error:

Executing SQL script in server

ERROR: Error 1067: Invalid default value for 'LastDate'
  `LastDate` DATE NOT NULL DEFAULT '0000-00-00' ,

SQL script execution finished: statements: 20 succeeded, 1 failed

Will check on Mac later tonight.
[27 Dec 2011 18:41] Valeriy Kravchuk
No crash with recent 5.2.37 on Mac OS X 10.5.6 also. Just same one error as on Windows XP. Please, check if you still have a crash with 5.2.37.
[3 Jan 2012 13:37] Lorenz Kahl
Thanks for your suggestion to update MySQL. Since it's not that easy (as I'm using the MySQL version bundled with MAMP) I tried something else - with success:
I copied the database (structure & data) using phpMyAdmin, then I updated the schema used by MWB to that new DB. Now the sync process completed successfully.
[20 Jan 2012 1:58] Alfredo Kojima
Was able to verify with provided model.
[27 Jan 2012 2:55] Philip Olson
Fixed as of 5.2.36:

Selecting and dragging tables to the diagram area would fail. A
workaround was to collapse the table list first and then drag it
over, although it was only possible to drag a single table.