Bug #63711 Access to the path 'util.pyc' is denied after down grading version
Submitted: 10 Dec 2011 16:33 Modified: 10 Dec 2011 16:46
Reporter: Eric Kent Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.2.35 CE Rev 7915 OS:Microsoft Windows (Windows 7)
Assigned to: CPU Architecture:Any

[10 Dec 2011 16:33] Eric Kent
Description:
I uninstalled 5.2.36 because it was crashing to often.  I rebooted and re-installed 5.2.35.  Nothing else was running.  As soon as the installation completed, I got this error:

Access to the path 'C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\python\lib\ctypes\util.pyc' is denied

I checked and the file exists, and I can open the file in notepad, (yes it is binary, but it shows the file can be opened.)

Exception = System.UnauthorizedAccessException
Message = Access to the path 'C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\python\lib\ctypes\util.pyc' is denied.
FullText = System.UnauthorizedAccessException: Access to the path 'C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\python\lib\ctypes\util.pyc' is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.File.Delete(String path)
   at MySQL.GUI.Workbench.Program.RemoveCompiledPythonFiles(String folder)
   at MySQL.GUI.Workbench.Program.RemoveCompiledPythonFiles(String folder)
   at MySQL.GUI.Workbench.Program.RemoveCompiledPythonFiles(String folder)
   at MySQL.GUI.Workbench.Program.RemoveCompiledPythonFiles(String folder)
   at MySQL.GUI.Workbench.Program.Main(String[] Args)

How to repeat:
Any time I try to open workbench I get the error.  I may need to try to go back to 5.2.36.  Please let me know if there is a work around.  I may try uninstalling all of MySQL, including the database engine, in case that helps.  I did upgrade the database to the current version, when I upgraded workbench.
[10 Dec 2011 16:37] Valeriy Kravchuk
This is a duplicate of bug #62709. If you can not upgrade to 5.2.36, please, run Workbench as Administrator.
[10 Dec 2011 16:46] Eric Kent
I uninstalled workbench, deleted the 'MySQL Workbench 5.2 CE' folder, which still had files in it.  Then I rebooted, and reinstalled 5.2.35.  It seems to work OK now.