Bug #63708 'unified installer' fails upgrading to self.
Submitted: 10 Dec 2011 15:27 Modified: 11 Dec 2011 15:17
Reporter: Peter Laursen (Basic Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.5.19, 5.6.3 OS:Microsoft Windows (7/64)
Assigned to: CPU Architecture:Any
Tags: qc

[10 Dec 2011 15:27] Peter Laursen
Description:
Action 15:55:33: INSTALL. 
1: MySQL Server 5.5 2: {0067268E-3A9D-491F-A1F0-15D1662F9DE3} 
Action 15:55:33: FindRelatedProducts. Searching for related applications
Action 15:55:33: AppSearch. Searching for installed applications
Action 15:55:33: LaunchConditions. Evaluating launch conditions
A later version of MySQL Server 5.5 is already installed. Setup will now exit.
1: MySQL Server 5.5 2: {0067268E-3A9D-491F-A1F0-15D1662F9DE3} 3: 3 

How to repeat:
I launch the installer and select 'upgrade' option. It tells me that there is a server intance that needs to be upgraded to 5.5.19.  I click 'gogo' and a msgbox pops up that upgrade has failed.  See log above.

It is part of the story that I actually do have 5.5.19 installed already. 5.5.18 was installed using the 'stand alone' .msi installer.  I upgraded to 5.5.19 downloadding the zip package and copying/replacing files to installation folder and executed 'mysql_upgrade' (the 'mysql_upgrade_info' file reads "5.5.19"). This upgrade procedure is chosen because of http://bugs.mysql.com/bug.php?id=56889. It is an annoyance un uninstall 5.6, upgrade 5.5 and install 5.6 again.

All servers installed in advance as mentioned here are 64 bit servers.

I also have WB 5.2.36 installed (what is latest).  No Connectors.

Suggested fix:
I am not sure if it is the unconventional upgrade procedure 5.5.18 > 5.5.19 that is (part of) the underlying reason.  But I don't think so as registry has no information as far as I can see about 'z' in x.y.z version. But as said I am not sure how the installer detects what needs to be upgraded.

1) Support 64 bit servers on 64 bit Windows platform with 'unified installer' (if this is the problem). I note that the 'unified installer' binary is installed to "\program files (x86)" -folder and not "\program files" folder on 64 bit Windows system. Or at least display a menaningfull error that 'this installer does not handle 64 bit programs - you must upgrade every installed MySQL program independently'.

2) If the installation process encounters an error like it does here it should be possible to detect 'beforehand' and display 'nothing to be upgraded'.  If 'unified installer' cannot upgrade softwares installed with 'standalone installer' also display a meaningfull error.

3) Kick the person(s) who is/are responsible for and consistently refuses to fix http://bugs.mysql.com/bug.php?id=56889.
[10 Dec 2011 15:29] Peter Laursen
one detail

Attachment: version.jpg (image/jpeg, text), 6.64 KiB.

[10 Dec 2011 15:31] Peter Laursen
OK .. I missed a detail.

uninstall menu actually displays 5.5.18.
'upgrade_info' and SELECT VERSION 5.5.19.
[10 Dec 2011 15:41] Peter Laursen
"A later version of MySQL Server 5.5 is already installed. Setup will now exit."

This is the same error as the 5.5 'stand alone' installer displays if a 5.6 server is installed too as reported here http://bugs.mysql.com/bug.php?id=56889. 

So basically this is the same bug. Handle it in this system as you like.
[11 Dec 2011 15:17] Peter Laursen
duplicate of http://bugs.mysql.com/bug.php?id=56889