Bug #6362 set sql_log_bin=0 does not work with replace queries
Submitted: 1 Nov 2004 11:44 Modified: 10 Nov 2004 22:55
Reporter: Sergey Frolovichev Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Replication Severity:S1 (Critical)
Version:4.0.18 OS:Linux (SuSe 9.1)
Assigned to: CPU Architecture:Any

[1 Nov 2004 11:44] Sergey Frolovichev
Description:
set sql_log_bin=0 does not work with replace. The replace and replace multiple query is always going to binary log! But it works fine on update and insert.

How to repeat:
Just make a set sql_log_bin=0 after this make any replace or replace multiple which will affect some rows in replicated tables - you'll see this query in binary log.
[1 Nov 2004 14:17] Victoria Reznichenko
Hi,

Thank you for the report, but I can't repeat it with  4.0.23-debug-log.
[1 Nov 2004 15:10] Sergey Frolovichev
As I understand this big is fixed in development tree? Can you confirm the bug was in 4.0.18? If all above is correct - I'll use the new version as soon as it will become stable ;-)
[10 Nov 2004 10:05] Sergey Frolovichev
4.0.22 has the same bug. Now our administrator will download 4.0.23 from CVS to check this bug was fixed in it.
[10 Nov 2004 10:25] Sergey Frolovichev
I'm sorry for this not a bug, i just have not read a small comment:
he statement is refused with an error if the client does not have that privilege. (Before MySQL 4.1.2, the statement was simply ignored in that case.) 
Ignored - this is very bad, but... So please check my next bug ;-)