Bug #63315 Cannot open workbench due to access error
Submitted: 18 Nov 2011 13:42 Modified: 18 Nov 2011 14:14
Reporter: Andrew Karandjeff Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.2.35 OS:Microsoft Windows (Win 7 Pro)
Assigned to: CPU Architecture:Any

[18 Nov 2011 13:42] Andrew Karandjeff
Description:
Received Access Path Exception when opening MySQL.  Cannot execute Workbench.

Exception = System.UnauthorizedAccessException
Message = Access to the path 'C:\Program Files (x86)\MySQL\MySQL Workbench CE 5.2.35\db_utils.pyc' is denied.
FullText = System.UnauthorizedAccessException: Access to the path 'C:\Program Files (x86)\MySQL\MySQL Workbench CE 5.2.35\db_utils.pyc' is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.File.Delete(String path)
   at MySQL.GUI.Workbench.Program.RemoveCompiledPythonFiles(String folder)
   at MySQL.GUI.Workbench.Program.Main(String[] Args)

How to repeat:
Try opening MySQL Workbench
[18 Nov 2011 14:14] Valeriy Kravchuk
This is a duplicate of bug #62709. Please, upgrade to 5.2.35.1 (.msi binaries) or run Workbench as Administrator.