Bug #63283 MEM Agent fails to validate software path when using non-default ini files
Submitted: 16 Nov 2011 10:39 Modified: 16 Nov 2011 12:39
Reporter: Chris Parker Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Enterprise Monitor: Installing Severity:S3 (Non-critical)
Version:2.3.7 OS:Linux (5.5)
Assigned to: CPU Architecture:Any

[16 Nov 2011 10:39] Chris Parker
I am currently upgrading all of our MEM Agents to the latest 2.3.7 release.

So far, the upgrades have worked well, however I have come to one server that runs 3 instances of MySQL and subsequently has 3 agents running.  To ensure we know which agent is monitoring which instance, we have 3 .ini files in the $AGENT_HOME/etc directory (Agent home being /var/lib/mysql/enterprise/agent)

The .ini files are as follows: mysql-monitor-agent-3308.ini, mysql-monitor-agent-3309.ini, mysql-monitor-agent-3310.ini

When I run the upgrade installer and get prompted to enter Agent Home, it reports:

Please specify the directory that contains the previous installation of the
MySQL Enterprise Monitor Agent

Installation directory [/home/mysql/mysql/enterprise/agent]: /var/lib/mysql/enterprise/agent

Warning: The directory /var/lib/mysql/enterprise/agent does not contain a
previous installation. Please select the right installation directory.
Press [Enter] to continue :

If I rename anyone of the ini files to the default of mysql-monitor-agent.ini the upgrade works fine and recognises AGENT_HOME as being valid.

How to repeat:
Change the ini filename to be non-default

Suggested fix:
Have the update program recognise non-default ini filename
[16 Nov 2011 11:37] Andrii Nikitin
Hi Chris,

Thank you for helping.
Upgrade when layout is changed is quite complex issue, so it was decided to just mention following in documentation:


"The update installer will not upgrade agents where you have changed or modified the filenames or directory layout of the installed agent, configuration files, or the startup files."

I am closing report as duplicate of bug #42198
[16 Nov 2011 12:39] Chris Parker
Ahhh cool ok - thanks - I only raised the BUG as I couldn't find that information anywhere else, i didn't think of reading the manual!