Bug #63098 mysqld got signal 11 -- no other specific symptoms
Submitted: 4 Nov 2011 0:31 Modified: 6 Aug 2012 22:34
Reporter: Anton Kuraev Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Optimizer Severity:S2 (Serious)
Version:5.0.91 OS:Linux (CentOS 5)
Assigned to: CPU Architecture:Any

[4 Nov 2011 0:31] Anton Kuraev
Description:
We had two MySQL server crashes this week, both servers crashed with "mysqld got signal 11" message, but there were no stack traces or other specific messages indicating exact problem.

We're not sure whether both crashes were caused by the same problem, however both of them occurred on the same day and different physical hosts.

Luckily we've got core dumps for both crashes (will upload to the ftp shortly). We briefly checked and the backtraces look differently, but one of them seems to be somewhat similar to this: https://bugs.launchpad.net/maria/+bug/860553

I'm also sending my.cnf and error logs from both servers.

How to repeat:
N/A
[4 Nov 2011 1:22] Anton Kuraev
it seems ftp.mysql.com is not available, so I cannot upload the core dumps

** server can't find ftp.mysql.com: NXDOMAIN
[4 Nov 2011 6:57] Shane Bester
Can you upload a .txt file on this bug report with outputs from gdb for each of the cores?

gdb /path/to/mysqld /path/to/core
bt
thread apply all bt
bt full

To get the query that crashed I suppose you could go into mysql_parse frame and print (char*)thd->query
Thanks!
[4 Nov 2011 7:47] Anton Kuraev
please find them attached
[19 Dec 2011 17:58] Shane Bester
just to index the stack trace content:

(gdb) bt
#0  in pthread_kill from /lib64/libpthread.so.0
#1  in handle_segfault at mysqld.cc:2380
#2  <signal handler called>
#3  in update_ref_and_keys  at sql_select.cc:3726
#4  in make_join_statistics at sql_select.cc:2589
#5  in JOIN::optimize (this=0x2aabc31a8ba0) at sql_select.cc:938
#6  in mysql_select at sql_select.cc:2352
#7  in handle_select at sql_select.cc:257
#8  in mysql_execute_command (thd=0x2adda6d0) at sql_parse.cc:3915
#9  in mysql_parse at sql_parse.cc:6470
[19 Dec 2011 18:00] Shane Bester
(gdb) bt
#0  in pthread_kill from /lib64/libpthread.so.0
#1  in handle_segfault at mysqld.cc:2380
#2  <signal handler called>
#3  in create_ref_for_key at sql_select.cc:5440
#4  in get_best_combination at sql_select.cc:5337
#5  in make_join_statistics at sql_select.cc:2866
#6  in JOIN::optimize at sql_select.cc:938
#7  in mysql_select at sql_select.cc:2352
#8  in handle_select at sql_select.cc:257
#9  in mysql_execute_command at sql_parse.cc:3915
#10 in mysql_parse at sql_parse.cc:6470
[20 Apr 2012 16:28] Sinisa Milivojevic
I have looked into source code and looks like possible RAM corruption ...

Do you still have crashes like this one ????
[24 May 2012 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[6 Aug 2012 22:34] Sveta Smirnova
This is duplicate of verified bug #65948