Bug #62833 Mysql Workbench Crashes repeatedly
Submitted: 19 Oct 2011 21:25 Modified: 19 Oct 2011 21:35
Reporter: isaac ali Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S1 (Critical)
Version:MySQL Workbench CE for Windows version 5 OS:Microsoft Windows (7 Ultimate - 64 bit edition)
Assigned to: CPU Architecture:Any

[19 Oct 2011 21:25] isaac ali
Description:
Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException (0x80004005): External component has thrown an exception.
   at MySQL.Grt.Db.Recordset.get_popup_menu_items(List`1 rows, Int32 column)
   at MySQL.GUI.Workbench.SqlIdeMenuManager.OnMenuOpening(Object sender, CancelEventArgs e)
   at System.Windows.Forms.ToolStripDropDown.OnOpening(CancelEventArgs e)
   at System.Windows.Forms.ToolStripDropDown.SetVisibleCore(Boolean visible)
   at System.Windows.Forms.ContextMenuStrip.SetVisibleCore(Boolean visible)
   at System.Windows.Forms.ToolStripDropDown.Show(Control control, Point position)
   at System.Windows.Forms.ContextMenuStrip.ShowInternal(Control source, Point location, Boolean isKeyboardActivated)
   at System.Windows.Forms.DataGridView.WmContextMenu(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.DataGridView.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Inserting values when creating an entity within EER Diagram

Suggested fix:
MySQL Workbench CE for Windows version 5.2.35

Configuration Directory: C:\Users\isaac\AppData\Roaming\MySQL\Workbench

Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2.35 CE

Cairo Version: 1.8.8

Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.

OpenGL Driver Version: 2.1.8784 FireGL

OS: Microsoft Windows 7 Ultimate Edition (build 7600), 64-bit

CPU: 2x Intel(R) Core(TM)2 Duo CPU     T9600  @ 2.80GHz, 6.0 GiB RAM

Active video adapter: ATI Mobility Radeon HD 4670

Installed video RAM: 1024 MB

Current video mode: 1920 x 1080 x 4294967296 colors

Used bit depth: 32

Driver version: 8.631.0.0

Installed display drivers: atiumd64.dll,atidxx64.dll,atiumdag,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll

Current user language: English (Trinidad and Tobago)
[19 Oct 2011 21:35] Alfredo Kojima
This is a duplicate of bug #60116