Bug #6278 MySQL service does not start
Submitted: 27 Oct 2004 7:43 Modified: 13 Jan 2006 16:02
Reporter: Sebastian Bergmann Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:4.1.7 OS:Microsoft Windows (Windows XP Professional SP-2)
Assigned to: Michael G. Zinner CPU Architecture:Any

[27 Oct 2004 7:43] Sebastian Bergmann
Description:
After installing the MySQL 4.1.7 release using the MSI installer I cannot start the MySQL server:

  MySQL wird gestartet.
  MySQL konnte nicht gestartet werden.

  Ein Systemfehler ist aufgetreten.

  Systemfehler 1067 aufgetreten.

  Der Prozess wurde unerwartet beendet.

How to repeat:
net start mysql
[27 Oct 2004 8:04] Sebastian Bergmann
Installing MySQL 4.1.7 by extracting the .ZIP-File to C:\ and registering the service manually works.
[27 Oct 2004 13:12] MySQL Verification Team
I wasn't able to repeat the service start failed using the MSI package on
XP SP2. Could you please elaborate the options you used during the
install process ?.

Thanks in advance.
[27 Oct 2004 14:46] Sebastian Bergmann
I installed it using the default values suggested by the installer.
[8 Dec 2004 15:06] Mark van 't Zet
I have noticed that when upgrading from older versions, an incompatible my.ini may have remained in the Windows system directory, causing service startup to fail. Removing the old my.ini solves this.
[8 Dec 2004 15:41] MySQL Verification Team
The note from Mr. Mark van 't Zet is valid and I am changing as
feature request for the installer verify at least the configuration
files on default places and asks their rename for the user.
[8 Jul 2005 10:59] Michel Polotto
Sorry, 9 months later and I  had the problem yesterday Problem still present in mysql-4.1.12a-win32 !!!

And I still can't get the thing to start. So I'm stuck.

Is this a one way communication path, only useful for TCX/MySQL, or can people who spend time reporting their problem also get some proper feedback on how to have an immediate fix to the problem, i.e. without having to wait for an unknown fix/version date?

And BTW how can I download older/intermediate version where are the versions prior to 4.0.24 or 4.1.12a or 3.xxx?? presumbaly there were since I've been using 3.21 quite satisfactorily, and I'd like to try some more since the two mentioned higher up don't work. Where are they, or have they become illegal by some kind of legal mumbo-jumbo?

Michel Polotto
[8 Jul 2005 11:02] Michel Polotto
Sorry forgot to add details Win XP SP2, mysql-4.1.12a-win32 still fails with/without my.ini removed. Figured it out myself (worth trying) but to no avail.

Perhaps some people listening on the other side to understand frustration after reading Miguel will fix it, sometime between then (Oct 2004) and now (july 2005)
[26 Aug 2005 17:27] darrell duffy
I had 4.0.18 installed on win xp. install path was C:\mysql\...
I uninstalled, rebooted and then installed 4.1.14 using the msi.
I'm using winxp SP2.

The config step failed because the service was still present. Of course the mysqld file was gone. Based on other forum items I have removed HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MySql registery keys including control sets 001 and 002. The service is still present and I can't find any more keys to remove. I'm still working to find the service in the registry and delete it.

Apparently the uninstall process has left registry keys around and the new install then cannot continue. Looks like a couple of fixes are possible:
(1) Uninstall remove all keys for the service.
(2) Or Install is more forgiving and updates the existing keys with the new path to the service - and any other relevant data.
It would seem that (2) is preferablel since it allows new installations to proceed in the face of bad previous uninstalls...

This is marked S3, but I'm down until I hack the registry, so it sounds like S2 to me.

Thanks for listening.

Darrell Duffy
[13 Jan 2006 14:11] Max Man
I tried to install mysql 5.0 in a Windows 2k sp4.  System say to me:

C:\>net start mysql
El servicio de MySQL está iniciándose.
El servicio de MySQL no ha podido iniciarse.

Error de sistema.

Error de sistema 1067.

El proceso ha terminado de forma inesperada.

(please translate to english)

In the same machine i was installed mysql 4.1.7 and it worked fine (was removed for install  5.0), then i tried to reinstall 4.1.7  but i  get  the same problem.

any advance?

Max
[13 Jan 2006 16:02] Michael G. Zinner
The problem with this issue is, that the new installer cannot detect the way one has configured his MySQL server when he did so manually (like with the old installers before 4.1.5). 

Therefore it is required to completely remove the old installation manually, including Windows Service, config files and installation files.

Please see the documentation.

http://dev.mysql.com/doc/refman/5.0/en/windows-upgrading.html

We had to break with the old installations to establish an easy and smooth way to handle updates in the new installer.

Please feel free to continue to work with the no-install packages which allow you to keep your existing workflow of upgrading and installing the server.
[20 Nov 2010 5:14] foxrom foxrom
Lo que tienen que hacer es abrir CMD e instalar el servicio de la siguiente manera

"C:\mysql4122\bin\mysqld.exe" --install "MySQL 4.1.22" --defaults-file="C:\mysql4122\my.ini"

C:\mysql4122\bin\mysqld.exe: es el sitio donde esta ese ejecutable
"MySQL 4.1.22": es el nombre para el servicio
--defaults-file="C:\mysql4122\my.ini": es el archivo que leerá el mysqld

y si te sale error al iniciar el servicio teneis que borra los archivos:

ib_logfile0
ib_logfile1
ibdata1

que se deben encontrar dentro de la carpeta de instalacion de mysql (en mi caso C:\mysql4122\data).

recuerda que siempre tienes que iniciar, reinicar o detener el servicio desde el administrador de servicios de windows, porque si lo haces por medio de comandos osea usando cmd y luego escribiendo C:\mysql4122\mysqld se volvera a crear el conflicto y tendras que borrar los archivos que antes mencione. Suerte.
[20 Nov 2010 5:34] foxrom foxrom
Nota: capaz necesites desinstalar el(los) servicios de mysql en antes de hacer los pasos sugeridos, para ello puedes usar abriendo cmd y ejecutando lo siguiente:
sc delete "MySQL 4.1.22"
o tambien
"C:\mysql4122\bin\mysqld.exe" --remove "MySQL 4.1.22"
y para estar seguro entras al regedit y buscas la cadena:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\MySQL 4.1.22 y la cadena HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\MySQL 4.1.22 y la cadena HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MySQL 4.1.22 y elimina todas ellas.