Bug #62685 Adding Firewall Rule failed during install
Submitted: 11 Oct 2011 19:38 Modified: 13 Jan 2015 7:53
Reporter: Sara Edwards Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.5.17, 5.5.19, 5.5.25 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: Adding, failed, firewall, install, rule

[11 Oct 2011 19:38] Sara Edwards
Description:
mysql-server-5.5-winx64-gpl:6 - Looking for valid template
mysql-server-5.5-winx64-gpl:13 - Found valid template.
mysql-server-5.5-winx64-gpl:20 - Attempting to process template.
mysql-server-5.5-winx64-gpl:26 - Processed template.
mysql-server-5.5-winx64-gpl:33 - Attempting to configure service.
mysql-server-5.5-winx64-gpl:40 - Configured service.
mysql-server-5.5-winx64-gpl:46 - Attempting to start service.
mysql-server-5.5-winx64-gpl:53 - Started service.
mysql-server-5.5-winx64-gpl:60 - Adding firewall rule for MySQL55 on port 3306.
mysql-server-5.5-winx64-gpl:66 - Adding firewall rule failed.
mysql-server-5.5-winx64-gpl:73 - Attempting to update security settings.
mysql-server-5.5-winx64-gpl:80 - Updated security settings.
mysql-server-5.5-winx64-gpl:86 - Attempting to verify command-line client shortcut.
mysql-server-5.5-winx64-gpl:93 - Verified command-line client shortcut.
mysql-server-5.5-winx64-gpl:100 - Product configuration controller finished configuration.

How to repeat:
Install MySQL
[11 Oct 2011 19:39] Sara Edwards
Did not add my OS
[11 Oct 2011 19:45] MySQL Verification Team
It's the 5.5.16 version?. Thanks.
[12 Nov 2011 7:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[19 Nov 2011 0:58] Christine Weigand
I've got the same problem, the with version 5.5.17
[18 Dec 2011 15:07] Valeriy Kravchuk
Please, check if the same problem still happens with a newer version, 5.5.19.
[20 Dec 2011 14:28] Vishal Gupta
The same problem is there in 5.5.19 too. Please suggest some solution!
[30 Dec 2011 15:57] Jichao He
For the shortcut, change ..."--defaults-file=C:\Program Files\MySQL\MySQL Server 5.5\my.ini"... into in the ..."--defaults-file=C:\Documents and Settings\All Users\Application Data\MySQL\MySQL Server 5.5\my.ini"... in Properties and this will help you to launch the command prompt of MySQL Server properly.

For the firewall, I notice that there is "MySQL" with port "3306" in the exceptions, and I have no idea for the failure.

P.S. Try to reinstall via seperated packages instead of MySQL Installer for Windows.
[25 Mar 2012 15:25] Valeriy Kravchuk
Does anybody still see this error on any Windows version with recent binaries, 5.5.22?
[2 Apr 2012 23:08] Jason Anonymous
System Installer log file

Attachment: SYSTEM installer.log (application/octet-stream, text), 33.58 KiB.

[2 Apr 2012 23:12] Jason Anonymous
Above is the log file that was generated when I was using the mysql-installer-5.5.22.0.msi file to create a developer installation on my Windows 7 Home Premium 64-bit laptop. While going through the configuration steps it failed to create a firewall rule. I looked over the log and it looks like the netsh command used by the installer is deprecated and now it looks like you would need to use  "netsh advfirewall firewall"

I'm going to attempt to add my firewall rule manually. Hope this helps w/ fixing the bug.
[12 Apr 2012 10:56] Morandini Fabio
me too!
I using mysql-installer-advanced-5.5.22.1.msi on my Windows XP SP3 32 bit (italian)

Error while the configuration steps failde to create a firewall rule.

In firewall rule mysql55 port 3306 is added!

when I try to connect to mysql DB : Cannot connect to MySQL Server on "127.0.0.1"!

data path: D:\MySQLData
bin path : C:\Programmi\MySQL\MySQL Server 5.5
Thanks
[2 May 2012 7:04] K M
This happens with version 5.5.23 as well:

mysql-server-5.5-winx64:60 - Adding firewall rule for MySQL55 on port 3306.
mysql-server-5.5-winx64:66 - Adding firewall rule failed.

Perhaps it's because I'm NOT running Windows Firewall?
[2 May 2012 9:42] Morandini Fabio
I solved the problem! Remove TCP/IP Microsoft version 6, from Network Properties in Win XP.
[3 May 2012 2:36] MySQL Verification Team
Please check if work-around of @Morandini Fabio works. Thanks.
[1 Jun 2012 14:03] Christopher Rohlfs
I encountered this problem with version 5.5.25 using Windows 7 (x64). I attempted to disable IP version 6, as suggested, using the following instructions:

http://support.microsoft.com/kb/929852#letmefixit

However, after reboot and reinstallation, the problem still occurs.
[1 Jun 2012 14:29] Christopher Rohlfs
I also tried removing IP 6 using the fixit4me application: http://support.microsoft.com/kb/929852#fixit4me

After running that, rebooting, and reinstalling, the problem still arose.
[3 Sep 2012 12:37] craik lee
Hello, everyone!
I also encountered this problem.
My MySQL edition is 5.5.27.2.
My OS is Windows Server 2008 R2 Enterprise.
Is there anyone who has solved this problem?
[24 Sep 2012 23:51] MySQL Verification Team
Please try version 5.5.27. I can't repeat on my own. Thanks.
[8 Oct 2012 1:47] MELERIX ...
MySQL 5.6.7 is affected by this bug too.
[18 Oct 2012 13:21] MySQL Verification Team
Thank you for the bug report.
[21 Oct 2012 22:13] Kerry Hughes
Bug is still there for MySQL 5.5.28 with windows installer.  Windows 2010

Does anyone have a fix?

mysql-server-5.5-winx64:6 - Looking for valid template
mysql-server-5.5-winx64:12 - Found valid template.
mysql-server-5.5-winx64:18 - Attempting to process template.
mysql-server-5.5-winx64:25 - Processed template.
mysql-server-5.5-winx64:31 - Attempting to configure service.
mysql-server-5.5-winx64:37 - Configured service.
mysql-server-5.5-winx64:43 - Attempting to start service.
mysql-server-5.5-winx64:50 - Started service.
mysql-server-5.5-winx64:56 - Adding firewall rule for MySQL55 on port 3306.
mysql-server-5.5-winx64:62 - Adding firewall rule failed.
mysql-server-5.5-winx64:68 - Attempting to update security settings.
mysql-server-5.5-winx64:75 - Updated security settings.
mysql-server-5.5-winx64:81 - Attempting to verify command-line client shortcut.
mysql-server-5.5-winx64:87 - Verified command-line client shortcut.
mysql-server-5.5-winx64:93 - Attempting to Add New MySQL Users
mysql-server-5.5-winx64:100 - Added New Users.
mysql-server-5.5-winx64:100 - Product configuration controller finished configuration.
[1 Nov 2012 0:06] Elliot Del Greco
STILL NOT WORKING!
[22 Dec 2012 3:31] MELERIX ...
MySQL 5.6.9 RC fails to add firewall rule too!
[6 Jan 2013 2:43] Benjamin Stevens
A couple of things look like potential issues here. This worked for me on Win7

First of all, is the windows firewall running? Ignore what it says under Control Panel > Windows Firewall, this is misleading in Windows Vista and later. 

Instead check under  Control Panel > Admin Tools > Services > Windows Firewall. If the service isn't running, start it. 

If the service is already running, have you ran through adding the exceptions manually?

Quote from: monkeypigs on November 16, 2012, 04:11:43 PM
You also need to open port 3306 on the windows firewall. As you've said that you are on Windows 7, you also have to add it to the windows firewall (even if it is disabled, it can still block services like SQL)

You can either do this via Control Panel > Admin Tools > Windows Firewall, and add new rules for port 3306

Or select start  > enter CMD into the search box, right click on it, select run as admin and enter

Code: [Select]
netsh advfirewall firewall add rule name="Open SQL Server Port 3306" dir=in action=allow protocol=TCP localport=3306

netsh advfirewall firewall add rule name="Open SQL Server Port 3306" dir=out action=allow protocol=TCP localport=3306

If you're running a third party firewall, try disabling that during the install (You can always manually add the exceptions later, but don't forget to restart your third party firewall)

Failing that, just untick the "Add exceptions to the firewall" box on the SQL install wizard and see what happens.