Bug #62667 Cluster NDB crashed with "Out of SendBufferMemory in sendSignal"
Submitted: 10 Oct 2011 13:09 Modified: 21 Nov 2016 12:34
Reporter: Steve Brown Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S1 (Critical)
Version:7.1.15a OS:Linux (Debian Lenny 64bit)
Assigned to: Bogdan Kecman CPU Architecture:Any
Tags: cluster ndb crash sendbuffermemory

[10 Oct 2011 13:09] Steve Brown
Description:
While importing data from a mysqldump into our (beta) production cluster, one disk node crashed. The out.log contained:

2011-10-10 12:30:54 [ndbd] INFO     -- Out of SendBufferMemory in sendSignal
2011-10-10 12:30:54 [ndbd] INFO     -- 
2011-10-10 12:30:54 [ndbd] INFO     -- Error handler shutting down system
2011-10-10 12:30:54 [ndbd] INFO     -- Error handler shutdown completed - exiting
2011-10-10 12:30:58 [ndbd] ALERT    -- Node 5: Forced node shutdown completed. Caused by error 2300: 'Generic error(Restart error). Temporary error, restart node'.

I've uploaded ndb_error_report_20111010140129.tar.bz2 to ftp.oracle.com/support/incoming

How to repeat:
Not too sure, happy to carry out any tests as required.
[18 Oct 2011 19:42] Matthew Montgomery
Please attach logs archive created from ndb_error_reporter.
[20 Oct 2011 10:17] Steve Brown
As I said, I've uploaded ndb_error_report_20111010140129.tar.bz2 to ftp.oracle.com/support/incoming

I can't attach due to the size limit.

Can you retrieve from your FTP server?
[20 Jan 2012 2:21] Kerlion He
I got same error with 7.1.15a. I think it is a bug of MTD, it is just report 1218 error when I ran it on non MTD mode.
[29 May 2015 7:47] Christian Tölle
Hi,

we had a crash with the same message this morning.. used version is:
ndb-7.3.3..
[29 May 2015 7:50] Christian Tölle
Tracelog of the error

Attachment: ndb_2_trace.log.2 (application/octet-stream, text), 1021.41 KiB.

[29 May 2015 9:12] Christian Tölle
short time before the crash, i got a SQL Query that was aborted with error, 
(HY000/1205): Lock wait timeout exceeded; try restarting transaction

it was a very small query. and the load of the server was very low too..
[21 Nov 2016 12:34] Bogdan Kecman
Hi, sorry for the late update, this bug is closed long time ago, can't find exact version but iirc it was 7.1.17. In any case it can't be reproduced in any of the recent versions.

take care
Bogdan Kecman