Bug #62563 INNOD DB CRASH
Submitted: 28 Sep 2011 15:12 Modified: 18 Oct 2011 22:08
Reporter: Gerardo Sánchez Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S2 (Serious)
Version:5.5.8 OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any
Tags: innodb

[28 Sep 2011 15:12] Gerardo Sánchez
Description:
I install wampserver 2.1 with mysql 5.5.8, i first get this error:

...............................................
110928  6:58:20 [Note] Plugin 'FEDERATED' is disabled.						
InnoDB: The InnoDB memory heap is disabled						
InnoDB: Mutexes and rw_locks use Windows interlocked functions						
InnoDB: Compressed tables use zlib 1.2.3						
110928  6:58:21  InnoDB: Initializing buffer pool, size = 128.0M						
110928  6:58:21  InnoDB: Completed initialization of buffer pool						
110928  6:58:21  InnoDB: highest supported file format is Barracuda.						
110928  6:58:26  InnoDB: 1.1.4 started; log sequence number 4718092						
110928  6:58:27 [Note] Event Scheduler: Loaded 0 events						
110928  6:58:27 [Note] wampmysqld: ready for connections.						
Version: '5.5.8'  socket: ''  port: 3306  MySQL Community Server (GPL)						
110928  7:08:04 [Note] Plugin 'FEDERATED' is disabled.						
InnoDB: The InnoDB memory heap is disabled						
InnoDB: Mutexes and rw_locks use Windows interlocked functions						
InnoDB: Compressed tables use zlib 1.2.3						
110928  7:08:04  InnoDB: Initializing buffer pool, size = 128.0M						
110928  7:08:04  InnoDB: Completed initialization of buffer pool						
110928  7:08:04  InnoDB: highest supported file format is Barracuda.						
InnoDB: Log scan progressed past the checkpoint lsn 4719026						
110928  7:08:05  InnoDB: Database was not shut down normally!						
InnoDB: Starting crash recovery.						
InnoDB: Reading tablespace information from the .ibd files...						
InnoDB: Restoring possible half-written data pages from the doublewrite						
InnoDB: buffer...						
InnoDB: Doing recovery: scanned up to log sequence number 4719036						
InnoDB: Last MySQL binlog file position 0 17570, file name .\mysql-bin.000024						
110928  7:08:11  InnoDB: 1.1.4 started; log sequence number 4719036						
110928  7:08:11 [Note] Event Scheduler: Loaded 0 events						
110928  7:08:11 [Note] wampmysqld: ready for connections.						
Version: '5.5.8'  socket: ''  port: 3306  MySQL Community Server (GPL)						
110928  8:26:51 [Note] Plugin 'FEDERATED' is disabled.						
InnoDB: The InnoDB memory heap is disabled						
InnoDB: Mutexes and rw_locks use Windows interlocked functions						
InnoDB: Compressed tables use zlib 1.2.3						
110928  8:26:51  InnoDB: Initializing buffer pool, size = 128.0M						
110928  8:26:51  InnoDB: Completed initialization of buffer pool						
110928  8:26:51  InnoDB: highest supported file format is Barracuda.						
InnoDB: Log scan progressed past the checkpoint lsn 4719133						
110928  8:26:51  InnoDB: Database was not shut down normally!						
InnoDB: Starting crash recovery.						
InnoDB: Reading tablespace information from the .ibd files...						
InnoDB: Restoring possible half-written data pages from the doublewrite						
InnoDB: buffer...						
InnoDB: Doing recovery: scanned up to log sequence number 4719143						
InnoDB: Last MySQL binlog file position 0 17570, file name .\mysql-bin.000024						
110928  8:26:57  InnoDB: 1.1.4 started; log sequence number 4719143						
110928  8:26:57 [Note] Event Scheduler: Loaded 0 events						
110928  8:26:57 [Note] wampmysqld: ready for connections.						
Version: '5.5.8'  socket: ''  port: 3306  MySQL Community Server (GPL)						
110928  8:54:25 [Note] Plugin 'FEDERATED' is disabled.						
InnoDB: The InnoDB memory heap is disabled						
InnoDB: Mutexes and rw_locks use Windows interlocked functions						
InnoDB: Compressed tables use zlib 1.2.3						
110928  8:54:25  InnoDB: Initializing buffer pool, size = 128.0M						
110928  8:54:25  InnoDB: Completed initialization of buffer pool						
110928  8:54:25  InnoDB: highest supported file format is Barracuda.						
InnoDB: Log scan progressed past the checkpoint lsn 4719143						
110928  8:54:25  InnoDB: Database was not shut down normally!						
InnoDB: Starting crash recovery.						
InnoDB: Reading tablespace information from the .ibd files...						
InnoDB: Restoring possible half-written data pages from the doublewrite						
InnoDB: buffer...						
InnoDB: Doing recovery: scanned up to log sequence number 4719153						
InnoDB: Last MySQL binlog file position 0 17570, file name .\mysql-bin.000024						
110928  8:54:29  InnoDB: 1.1.4 started; log sequence number 4719153						
110928  8:54:29 [Note] Event Scheduler: Loaded 0 events						
110928  8:54:29 [Note] wampmysqld: ready for connections.						
Version: '5.5.8'  socket: ''  port: 3306  MySQL Community Server (GPL)						
............................................................

Looking in google i get a lot of post reporting the same error, i find an posible fix but it not work:
my.ini:
innodb_data_file_path = ibdata1:10M:autoextend
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

I get this new errors:
..........................................................
110928 10:14:37 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
110928 10:14:37  InnoDB: Initializing buffer pool, size = 16.0M
110928 10:14:37  InnoDB: Completed initialization of buffer pool
110928 10:14:37  InnoDB: highest supported file format is Barracuda.
110928 10:14:39  InnoDB: 1.1.4 started; log sequence number 4719163
110928 10:14:39 [Note] Event Scheduler: Loaded 0 events
110928 10:14:39 [Note] wampmysqld: ready for connections.
Version: '5.5.8'  socket: ''  port: 3306  MySQL Community Server (GPL)
110928 10:15:42 - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=16777216
read_buffer_size=262144
max_used_connections=1
max_threads=151
thread_count=1
connection_count=1
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 133447 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x29e6f78
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
004F4B80    mysqld.exe!?make_field@Field@@UAEXPAVSend_field@@@Z()
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 02AB1590=SHOW COLUMNS FROM Personas LIKE 'FechaCumpleanos'
thd->thread_id=1
thd->killed=NOT_KILLED
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
............................................................

I work fine for 3 year aprox. with wamp 2.0 and mysql 5.0.51a, this is a new error, then it is not programming errors in my software (i guess)

Thanks

How to repeat:
add this lines to my.ini

my.ini:
innodb_data_file_path = ibdata1:10M:autoextend
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50
[28 Sep 2011 15:25] Miguel Solorzano
Could you please try latest version 5.5.16 and if the problem persist please provide a complete test case (tables/data/query) private if you wish. Thanks in advance.
[28 Sep 2011 17:24] Valeriy Kravchuk
What about checking with 5.5.16 and providing complete test case? 

You can put compressed error log on some (FTP?) server and publish URL here.
[29 Sep 2011 18:54] Gerardo Sánchez
Sorry, complete test is not possible, i revert changes in my custommer server. The error happends starting windows (services?), when my app calls first SELECT query. I saved data stored in old mysql (using phpmyadmin export command), i unninstall wampserver 2.0b, install wampserver 2.1 and reload data using phpmyadmin import command.

You could download files at: http://www.megaupload.com/?d=YIBERQH9

I delete data in "Personas" table because it has private info, but i think it is not necesary data

File uploaded has "mysql-bin" files, i guess that is error information, please check it

File is available for 21 days, megaupload delete before this time.

I hope this info be usefull

Let me know if you need any more
[11 Oct 2011 14:52] Miguel Solorzano
Are you tried 5.5.16 how Valeriy asked before?. Thanks.
[12 Oct 2011 20:52] Gerardo Sánchez
I can easily reproduce error in mysql 5.5.8, but in mysql 5.5.16 don't raize any error, i think it is already fixed. Thanks

I am using wamp server 2.2a (32 bits)
[18 Oct 2011 22:08] Miguel Solorzano
Closed according last comment. Thanks for the feedback.