Bug #62385 Unhandled exception while opening SQL Editor
Submitted: 8 Sep 2011 16:06 Modified: 24 Sep 2011 12:01
Reporter: Piotr Szturmaj Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:5.2.34 CE rev 7780 OS:Windows (XP 32-bit)
Assigned to: CPU Architecture:Any
Tags: sql editor unhandled exception access violation

[8 Sep 2011 16:06] Piotr Szturmaj
First time when I installed MySQL Workbench it worked fine. I opened SQL Editor, created database and executed my import sql script. All tables were created and I closed the workbench.

Now, I run MySQL Workbench, then I double click on "Local instance MySQL" in the left panel. Splash window "Opening SQL Editor" appears and suddenly my debugger asks to handle this exception:

Unhandled exception at 0x038f70ce in MySQLWorkbench.exe: 0xC0000005: Access violation reading location 0x00000010.

Additional screenshot:

How to repeat:
I don't think it could be reproduced, because one time it worked, but second time it didn't. Also I'm sorry, because I can't provide my SQL script.

Suggested fix:
As the reading location 0x00000010 suggests, program is trying to read at 16 byte offset from a NULL pointer. That should be easily traced in source code.
[9 Sep 2011 18:08] Alfredo Kojima
Does it still crash if you try to connect again?
[9 Sep 2011 18:15] Piotr Szturmaj
Yes, it crashes everytime I run SQL Editor
[24 Sep 2011 8:39] Valeriy Kravchuk
Please, check if this problem ever happens in your environment with a newer version, 5.2.35.
[24 Sep 2011 12:01] Piotr Szturmaj
Problem seems to be fixed, thank you.