Bug #62370 crash right after starting
Submitted: 7 Sep 2011 8:33 Modified: 20 Sep 2011 20:53
Reporter: Dennis Geus Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.34 OS:Microsoft Windows (7 Pro. 32 bit)
Assigned to: CPU Architecture:Any
Tags: crash

[7 Sep 2011 8:33] Dennis Geus
Description:
Workbench crashes right after showing the splash screen.

below the eventviewer log file details

Application: MySQLWorkbench.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.ArgumentException
Stack:
   at System.Drawing.Font.CreateNativeFont()
   at System.Drawing.Font.Initialize(System.Drawing.FontFamily, Single, System.Drawing.FontStyle, System.Drawing.GraphicsUnit, Byte, Boolean)
   at System.Drawing.Font.Initialize(System.String, Single, System.Drawing.FontStyle, System.Drawing.GraphicsUnit, Byte, Boolean)
   at System.Drawing.Font..ctor(System.String, Single, System.Drawing.FontStyle, System.Drawing.GraphicsUnit, Byte)
   at MySQL.GUI.Workbench.ExceptionDialog.InitializeComponent()
   at MySQL.GUI.Workbench.ExceptionDialog..ctor()
   at MySQL.GUI.Workbench.ExceptionDialog..ctor(System.String, System.String)
   at MySQL.GUI.Workbench.MainForm.HandleException(System.Object)
   at MySQL.GUI.Workbench.Program.Main(System.String[])

How to repeat:
Just start mysql Workbench
[7 Sep 2011 20:00] Miguel Solorzano
Thank you for the bug report. Looks same issue of http://bugs.mysql.com/bug.php?id=62374. Please try the workaround commented there to use the zipped version. Thanks.
[8 Sep 2011 6:55] Dennis Geus
I've uninstalled Workbench, deteleted the folder, extracted the mysql-workbench-gpl-5.2.34-win32-noinstall.zip
but, no luck.
After opening workbench.exe it crashes at the spashscreen just as the other one did.
[8 Sep 2011 7:05] Dennis Geus
Also tried to run in XP compatibility mode and run as administrator but that didn't work.
[9 Sep 2011 17:46] Alfredo Kojima
Did you remove some system font?
[12 Sep 2011 11:23] Dennis Geus
@Alfredo

No I Didn't delete any system fonts (not that I know) but that remark just got me thinking.

I remembered getting a warning few weeks ago when I clicked on a menu item in Code4wards RoyalTS, giving me a message mentioning tahoma font. I didn't pay much attention to it then.

So I've copied tahoma (regular and bold) from another windows machine to my fonts directory.
I got the message that the fonts already exists but I choose to overwrite them.

Problem solved.
Workbench starts without crashing in the splashscreen.
[13 Sep 2011 8:40] Valeriy Kravchuk
So, can we assume that the problem was not related to any bug in Workbench?
[13 Sep 2011 9:23] Dennis Geus
Yes you can.
It's not a bug in Workbench.