Bug #62347 MySQL Workbench 5.2.34 building fails on Oneiric (Ubuntu 11.10) beta
Submitted: 5 Sep 2011 6:22 Modified: 9 Jan 2015 10:18
Reporter: Olivier Berten Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.34, 5.2.35 OS:Linux (Ubuntu 11.10)
Assigned to: Assigned Account CPU Architecture:Any

[5 Sep 2011 6:22] Olivier Berten
Description:
Since the mysql-workbench-gpl-5.2.34-1ubu1010 version hangs on splash screen, I tried compiling it. Unfortunately it doesn't work...

How to repeat:
./autogen.sh
make
[5 Sep 2011 6:24] Olivier Berten
build log

Attachment: mysql-workbench-oneiric-build.log.gz (application/x-gzip, text), 33.24 KiB.

[5 Sep 2011 14:47] Peter Phillips
I Have the same issue when using 11.10, when the application hangs on splash screen if I quit the application the home screen then loads. The application then freezes on "Opening SQL Editor".
[14 Sep 2011 1:16] Miguel Solorzano
Are you tried the *.deb package from our download page?

http://dev.mysql.com/downloads/workbench/5.2.html

Thanks.
[14 Sep 2011 6:54] Olivier Berten
As you can read in the description of the bug "the mysql-workbench-gpl-5.2.34-1ubu1010 version hangs on splash screen", yes I did... and it doesn't work anymore with Ubuntu 11.10, that's why I tried compiling it...
[19 Sep 2011 21:16] Olivier Berten
With recent versions of Oneiric, the packaged version works but the source still doesn't build.
[27 Sep 2011 9:09] Holger Knust
I just downloaded the 5.2.35 package and it hangs on Ubuntu 11.10 at the splash screen.
[27 Sep 2011 9:39] Holger Knust
Minor correction. Version 5.2.35 rev 7915 hangs when started from the Dash. If I quit the app from the launcher at that point, the main window will show and the app appears to be working.
[27 Sep 2011 10:58] Julien Pepy
The application only hangs in splash screen when started from Unity Launcher. When started from terminal, it runs just fine.
[29 Sep 2011 0:51] Jeremy Dinsel
I am experiencing this problem, too. If I strace the mysql-workbench-bin command, I find it appears to be stuck polling the unix socket in /tmp/.X11-unix/XO

socket(PF_FILE, SOCK_STREAM|SOCK_CLOEXEC, 0) = 6
connect(6, {sa_family=AF_FILE, path=@"/tmp/.X11-unix/X0"}, 20) = 0
getpeername(6, {sa_family=AF_FILE, path=@"/tmp/.X11-unix/X0"...}, [20]) = 0
[a couple fcntl, poll, writev, read, poll, read, etc occur and then]
read(6, 0x1e128f4, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
read(6, 0x1e128f4, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
read(6, 0x1e128f4, 4096)                = -1 EAGAIN (Resource temporarily unavailable)

The process seems to continually writev to this file descriptor, then poll (Timeout), then read and read again with the Resource temporarily unavailable. I haven't found many times where the read of the unix socket returns successfully.
[29 Sep 2011 15:54] Janne Snabb
The most recent .deb freezes also here on Ubuntu 11.10 (oneiric) beta (x86_64).

In my case there is no difference if I start it from command line in a terminal or from launcher.

I am using Xubuntu variation of Ubuntu (with Xfce desktop environment).
[29 Sep 2011 19:37] Richard Ayotte
Same problem here with Ubuntu 11.10, Gnome Shell, AMD64.

It hangs on startup until I close the splash screen and then I get this message.

Warning! Can't use connect with timeout in paramiko 1.7.7.1 (George)
Log levels '0111000'
Ready.

I can't use the SQL editor, it just hangs.
[4 Oct 2011 18:32] Andrew Ernst
When I strace the command, I'm seeing the splash screen.  If I choose "quit" from the gnome-shell menu, the splash screen goes away, and the application loads.  It looks like the hang is in the wait4 call, with regards to wb_utils_grt.py on my computer (Ubuntu 11.10, up-to-date from today, x86_64)

wait4(-1, Traceback (most recent call last):
  File "/usr/lib/mysql-workbench/modules/wb_utils_grt.py", line 119, in <module>
    if [int(i) for i in pyversion.split(" ")[1].strip().split(".")] < [2, 6, 0]:
ValueError: invalid literal for int() with base 10: '2+'
** Message: Failed loading module '/usr/lib/mysql-workbench/modules/wb_utils_grt.py' (python)
Warning! Can't use connect with timeout in paramiko 1.7.7.1 (George)
[4 Oct 2011 18:38] Andrew Ernst
Following up on my last comment, the output of the command "python --version" returns "Python 2.7.2+" and the "+" symbol is what I believe is causing this error.  Not 100% sure, but I'll leave that up to the developers.
[7 Oct 2011 7:13] Valeriy Kravchuk
Please, check if the same problem still happens with a newer version, 5.2.35.
[7 Oct 2011 7:48] Yoann Galland
always the same problem for me even with the 5.2.35 ...
[7 Oct 2011 9:06] Janne Snabb
I have this problem with 5.2.35 (as I stated in my comment "the most recent version").
[12 Oct 2011 22:02] Richard Ayotte
Anyone find a workaround?

The following messages repeat endlessly when Workbench is started.

[pid 12064] 17:49:21.235310 writev(6, [{"5\30\4\0\23\306 \3\3\0 \3\17\0\17\0007\0\7\0\24\306 \3\23\306 \3\0\5\1\0"..., 1284}, {NULL, 0}, {"", 0}], 3) = 1284
[pid 12064] 17:49:21.237247 read(6, 0x1b893b4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
[pid 12064] 17:49:21.237409 read(6, 0x1b893b4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
[pid 12064] 17:49:21.237534 poll([{fd=3, events=POLLIN}, {fd=4, events=POLLIN}, {fd=6, events=POLLIN}], 3, 0) = 0 (Timeout)
[pid 12064] 17:49:21.237645 read(6, 0x1b893b4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
[pid 12064] 17:49:21.237733 poll([{fd=3, events=POLLIN}, {fd=4, events=POLLIN}, {fd=6, events=POLLIN}], 3, 0) = 0 (Timeout)
[pid 12064] 17:49:21.238286 poll([{fd=6, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=6, revents=POLLOUT}])
[14 Oct 2011 9:54] Emilio Nicolás
Same case here! I am thinking in downgrading..
[14 Oct 2011 13:38] Javier Alvarez
Same problem here.. mysql-workbench-gpl-5.2.35-1ubu1104-i386.deb
[14 Oct 2011 14:07] Ian Bussieres
Same for me as well.
[14 Oct 2011 17:56] Jim Rorie
An interesting observation. .53 hangs at the splash screen under oneiric.  If I right click the mysql unity icon and select "quit", the splash screen disappears and the workbench starts.  Go figure.
[14 Oct 2011 17:59] Jason Normore
I can confirm this workaround for gnome shell.. Open mysql workbench, go to activities view and click the X in the corner of mysql splash screen (within activities view only) and workbench starts normally after a few seconds.
[14 Oct 2011 18:03] Jason Normore
Although now it hangs at the "Opening SQL Editor" dialog when you try to connect to something. I forgot to mention that I'm running mysql-workbench 5.2.35 on oneiric.
[14 Oct 2011 18:06] Jim Rorie
Confirmed that the SQL editor connection hangs, but the administrative connections appear to work
[14 Oct 2011 18:52] Janne Snabb
Workaround confirmed working on Xubuntu 11.10 with Xfce desktop as well.

However I can not open the SQL Editor as it gets stuck at another splash screen. And the clever trick that Jim observed does not work with that.

Do you guys see this issue as well?
[14 Oct 2011 21:48] George Earp
Same here... Workbench freezes on the splash screen, running Ubuntu 11.10 and MySQL Workbench 5.2.35
[15 Oct 2011 10:00] Lluis Turro
Could it be the Gtk nightmare? Now I get a freezing splash when 'SQL Editor loading...' using oxygen-gtk. Just tried with raleigh and then freezes the initial splash screen.
[15 Oct 2011 13:07] Eduardo Pinheiro
Same here. Workbench freezes on the splash screen, running Ubuntu 11.10 and MySQL
Workbench 5.2.35
[15 Oct 2011 13:39] Babos Csaba
And the same here too. Hanging on splashscreen, and when I choose quit, then it running, except the query window. It just hangs...
[15 Oct 2011 15:19] Sean Madsen
Broken for me too on Kubuntu 11.10. Really looking forward to a fix here. Having to use a separate machine for MySQL work.
[15 Oct 2011 20:40] Alfredo Kojima
Bug #62751 is a duplicate
[16 Oct 2011 9:00] Assaf Hershko
Exact same problem (hangs on splash screen, quitting gets you to the main display but connection then fails) on Ubuntu 11.10 (after an upgrade from 11.04) and Workbench 5.2.35. Would be great to get some acknowledgement that this is being looked at. Thanks.
[16 Oct 2011 10:04] Mathieu Panos
Same here. Impossible to use MySQL Workbench after an upgrade to Ubuntu 11.10.

Very annoying. It would be good to know that someone is working on this!
[16 Oct 2011 13:35] _ _
Exact same problem with Ubuntu 11.10 (64 bit).
Is anybody working on this issue?
[16 Oct 2011 18:48] Assaf Hershko
To clarify - Oneiric (Ubuntu 11.10) is no longer in beta, and this critical bug happens even after re-installing from your site.

i.e. - Workbench isn't working on the recent version of the most popular Linux distribution. Can you please assign someone to look into it? Thanks!
[17 Oct 2011 2:11] Jose Rivera
Bug confirmed on Ubuntu 11.10 x86_64 for MySQL Workbench 5.3.35 installed from the DEB package.

The previously listed workaround for getting it to load works for me. I'm running on GNOME Classic desktop, and I have to right-click the panel in the Window List and select Close to get it to load.
[17 Oct 2011 10:39] Gabriele Tozzi
Same here.
Kubuntu 11.10 ans mysql workbench 5.2.35 (.deb package).
[17 Oct 2011 13:10] Sidney Lins
Same problem here.
Ubuntu 11.10 - I just downloaded and installed the *5.2.35.11.04*.deb right now from mysql.com but the error persists.
[17 Oct 2011 13:18] jiawei fang
I have the same problem too. MySQL workbench 5.2.35 can't connect to the database. And the model design tool can't synchronize the model and db.
[17 Oct 2011 13:31] Maksym Yehorov
Patch to fix compilation and freezes

Attachment: 5.2.35-ubuntu_11_10_compile_fix.patch (application/octet-stream, text), 1.30 KiB.

[17 Oct 2011 13:34] Maksym Yehorov
Hi,

We have spotted and fixed problems on Ubuntu 11.10. Please use attached patch file to fix build. The binaries may appear later.
[17 Oct 2011 14:11] Emilio Nicolás
Thanks!

Someone has tried it?

Does it work fine?
[17 Oct 2011 16:45] George Earp
We have to download the source code, apply the patch and recompile it, right ?!
[17 Oct 2011 17:32] Maksym Yehorov
At the moment the fastest way is to compile from src. I'll update mysqlworkbench.org blog with instructions.
[17 Oct 2011 21:15] Paulo Zarpelon
Hello,
build is not as simple as it is on the blog. I believe that my machine does not have many requirements to compile (libs / other programs).

I tried to compile, but got many errors (perhaps by inexperience)

Can someone provide this fix?
Paulo
[17 Oct 2011 21:19] Maksym Yehorov
This is a short guide to build: http://mysqlworkbench.org/?p=1221
[17 Oct 2011 21:30] Yoann Galland
I confirm the patch works.

I downloaded the sources of the version 5.2.35.
I applied the patch.
Compile ... make ... install

and now all works well
[17 Oct 2011 21:41] Lluis Turro
For those desperates as I was:

Workbench works on a Kubuntu 11.04 in Virtualbox. I was desperate and did't want to modify my system in order to compile sources. Install Virtualbox, create a box with Kubuntu 11.04 and then install Workbench. In 2h you'll get Workbench running, system clean and once works again, easy to remove.
[18 Oct 2011 1:51] J O
Just press ALT-F4 after the splash.

http://mysqlworkbench.org/?p=1217
[18 Oct 2011 12:30] Alfredo Kojima
Bug #62788 is a duplicate
[18 Oct 2011 22:38] Olivier Berten
For those interested: https://launchpad.net/~olivier-berten/+archive/misc
[19 Oct 2011 8:03] Lasse Makholm
Fix confirmed here too. Patched, built and running smoothly on Ubuntu 11.10 x86_64.

Thanks!

Any chance of a new release?
[20 Oct 2011 13:07] Vladimir Zurita
I tested the Olivier Berten's package and it works ok in Ubuntu 11.10, the only problem is I can not run queries using [ctrl] + [enter], instead, I use the menu option.
[20 Oct 2011 13:23] Luis Arias
Thanks for the packages in your ppa Olivier, they work fine for me on 11.10.
[20 Oct 2011 13:26] Babos Csaba
Thank you for your build Olivier. 
It works fine, the query with the CTRL+ENTER start too. 
Great work!
[22 Oct 2011 8:29] Lluis Turro
Thanks J O, Alt+F4 works!
[24 Oct 2011 12:31] Luc Steffens
Olivier Berten ++
Works on my Ubuntu 11.1O (with Ctrl+Enter)

For those who just likes the list of commands to execute:

sudo add-apt-repository ppa:olivier-berten/misc
sudo apt-get update
sudo apt-get install mysql-workbench-gpl
[27 Oct 2011 14:50] Van Stokes
I would like to verify this problem in 5.2.34 and 5.2.35.
I installed the deb x64 distribution and it hangs at launch at the splash screen. If I "quit" the splash screen (kill it) the launch continues into the main application.
[5 Nov 2011 15:10] Steven Van Poeck
Olivier Berten's PPA install works flawlessly on Oneiric AMD-64 on my DELL Latitude e6510.

Merci Olivier !
[9 Nov 2011 8:46] dennis lee
I can get it open by quitting the splash screen on ubuntu 11.10. It will then start again and display the gui.
[21 Nov 2011 5:52] Philip Olson
Fixed as of 5.2.36:
+        On Ubuntu 11.10, &workbench; would freeze at the startup splash
+        screen.
[3 Dec 2011 13:58] Rafal Janicki
Solution with patch and compiling source works fine on 11.10, thanks a lat :)
[20 Dec 2012 1:14] Javier Domingo
Shouldn't this be marked as fixed?