Bug #62328 Cyrillic (national symbols) are not displayed properly in text objects
Submitted: 2 Sep 2011 8:11 Modified: 6 Nov 2014 6:16
Reporter: Igor Demishev Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.34 CE (7780) OS:Microsoft Windows (XP, 7)
Assigned to: CPU Architecture:Any
Tags: cyrillic, display error, national symbols, Text Object

[2 Sep 2011 8:11] Igor Demishev
Description:
In the text object of the diagramm, when I write some text to the 'text' field in my national langage (cyrillic), all it's symbols are displayed as squares. Nevertheless, at the diagramm all seems well, as in the 'name' field.

Screenshot: http://dl.dropbox.com/u/12404728/mysql_bench_bug.png

How to repeat:
Just try to type to that field some national text (cyrillic) or copy this test text: 'Привет! Я тестовый текст!'

Suggested fix:
Ah, if I would new it
[2 Sep 2011 9:04] Valeriy Kravchuk
Thank you for the problem report. 

Probably this can be changed by setting some other font in Options, but anyway the problem is visible in default configuration on (English) Windows versions.
[2 Sep 2011 10:13] I D
Still watching this bug with all fonts set as Arial (it should be perfect in Arial). Tahoma doesn't help either.

PS: Changing fonts via user interface is hell, because I need to put font names manually and there is some strange bug - when I double click/click/press space or do enything else, the field doesn't become editable in most cases. Only 1 of 20 tries works..
[7 Feb 2012 13:39] Mike Lischke
Bug #62345 was marked as a duplicate of this one.
[14 Mar 2012 13:19] lyme lumasag
The font 'Times New Roman' does not support style 'Regular' statement always appear whenever i enters to query database.
[14 Mar 2012 13:22] lyme lumasag
The font 'Times New Roman' does not support style 'Regular' statement always appear whenever i enters to query database. It appears to be an error to my workbench, what can I do about this? Hope you can provide some answer to my problem asap. tnx!
[5 Nov 2014 16:55] Johannes Taxacher
Posted by developer:
 
fix confirmed in 6.2.4
[6 Nov 2014 6:16] Philip Olson
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 6.2.4 release, and here's the changelog entry:

Font selection and support was improved. Some fonts, such as Cyrillic
fonts, were not displayed properly.

Thank you for the bug report.