Bug #62242 Attempting to open new schema for first time. Got this error - no clue
Submitted: 23 Aug 2011 20:26 Modified: 28 Oct 2011 0:03
Reporter: brian Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.2.34 rev7780 OS:Microsoft Windows (XP Pro sp4)
Assigned to: CPU Architecture:Any

[23 Aug 2011 20:26] brian
Description:
Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException (0x80004005): External component has thrown an exception.
   at Db_sql_editor.exec_sql(Db_sql_editor* , basic_string<char\,std::char_traits<char>\,std::allocator<char> >* , shared_ptr<Sql_editor>* , Boolean , Boolean , Boolean )
   at MySQL.GUI.Workbench.Db_sql_editor.exec_sql(String sql, Boolean active_editor, Boolean wrap_with_non_std_delimiter)
   at MySQL.GUI.Workbench.DbSqlEditor.DoExecuteSqlScript(Boolean currentStatementOnly)
   at MySQL.GUI.Workbench.DbSqlEditor.ExecuteSqlScript()
   at MySQL.GUI.Workbench.DbSqlEditor.OnPartialRefresh(Int32 what)
   at MySQL.Grt.RunWrappedDelegate1<void\,void\,int\,int\,MySQL::Grt::DelegateSlot1<void\,void\,int\,int>::ManagedDelegate>.native_callback(Int32* a1)
   at sigc.pointer_functor1<int const &,void>.()(pointer_functor1<int const \&\,void>* , Int32* _A_a1)
   at sigc.adaptor_functor<sigc::pointer_functor1<int const &,void> >.operator()<int const &>(adaptor_functor<sigc::pointer_functor1<int const \&\,void> >* , Int32* _A_arg1)
   at sigc.internal.slot_call1<sigc::pointer_functor1<int const &,void>,void,int const &>.call_it(slot_rep* rep, Int32* a_1)
   at sigc.slot1<void,int const &>.()(slot1<void\,int const \&>* , Int32* _A_a1)
   at sigc.adaptor_functor<sigc::slot<void,int const &,sigc::nil,sigc::nil,sigc::nil,sigc::nil,sigc::nil,sigc::nil> >.operator()<int const &>(adaptor_functor<sigc::slot<void\,int const \&\,sigc::nil\,sigc::nil\,sigc::nil\,sigc::nil\,sigc::nil\,sigc::nil> >* , Int32* _A_arg1)
   at sigc.internal.slot_call1<sigc::slot<void,int const &,sigc::nil,sigc::nil,sigc::nil,sigc::nil,sigc::nil,sigc::nil>,void,int const >.call_it(slot_rep* rep, Int32* a_1)
   at sigc.internal.signal_emit0<void,sigc::nil>.emit(signal_impl* impl)
   at MySQL.Forms.WizardImpl.nextClick(Object sender, EventArgs arguments)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

occurred upon clicking "Finish" on the open dialog.

How to repeat:
I have no idea for you- but its consistent and repeatable on my system.
[23 Aug 2011 20:29] brian
BTW, the data base is currently empty - just created (Forward engineer) and was trying to "Edit table data"
[23 Aug 2011 22:22] MySQL Verification Team
Could you please provide output of Help->System Info. Thanks.
[23 Sep 2011 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[26 Sep 2011 18:52] brian
Requested info:
MySQL Workbench CE for Windows version 5.2.34

Configuration Directory: C:\Documents and Settings\Brian\Application Data\MySQL\Workbench

Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE

Cairo Version: 1.8.8

Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.

OpenGL Driver Version: 2.0.5885 WinXP Release

OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)

CPU: 2x Intel(R) Pentium(R) 4 CPU 3.40GHz, 1.0 GiB RAM

Active video adapter: 256MB ATI RADEON X600

Installed video RAM: 256 MB

Current video mode: 1280 x 1024 x 4294967296 colors

Used bit depth: 32

Driver version: 6.14.10.6618

Installed display drivers: ati2dvag.dll

Current user language: English (United States)
[27 Sep 2011 13:04] MySQL Verification Team
Please try version 5.2.35. Thanks.
[28 Oct 2011 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".