Bug #62215 mysqld_safe: line 144: 7400 Segmentation fault nohup
Submitted: 19 Aug 2011 18:25 Modified: 30 Jan 2012 18:37
Reporter: MySQL Guru Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Server: Tests Severity:S7 (Test Cases)
Version:5.5.15 OS:Linux (Red Hat Enterprise Linux Server release 5.4 (Tikanga))
Assigned to: CPU Architecture:Any
Tags: BENCHMARK, bug, crash me, MySQL, test, test suite

[19 Aug 2011 18:25] MySQL Guru
Description:
I am having a lot of trouble running MySQL test framework and crash me because MySQL keeps crashing when I run any of bug finding test or crash me test.

I ran crash me with the following options:

sudo perl ./crash-me.sh --host=127.0.0.1:3307 --server=MySQL --log-queries-to-file=/tmp/sqls.txt --user=crash --password=password --check-server --force

and found out that the screen where mysqld_safe was manually started gives the following message.

 bin/mysqld_safe: line 144:  8638 Segmentation fault      nohup /usr/local/mysql-5.5.15/bin/mysqld --basedir=/usr/local/mysql-5.5.15 --datadir=/data --plugin-dir=/usr/local/mysql-5.5.15/lib/plugin --user=mysql --log-error=/var/log/mysqld.log --open-files-limit=65535 --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/lib/mysql/mysql.sock --port=3307 < /dev/null >> /var/log/mysqld.log 2>&1 >> /var/log/mysqld.log 2>&1
110819 13:14:56 mysqld_safe Number of processes running now: 0
110819 13:14:56 mysqld_safe mysqld restarted

Then I ran the query that crash me tried running and crashed in a MySQL command line session and got the following:

select 1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1;
ERROR 2013 (HY000): Lost connection to MySQL server during query
bin/mysqld_safe: line 144: 10206 Segmentation fault      nohup /usr/local/mysql-5.5.15/bin/mysqld --basedir=/usr/local/mysql-5.5.15 --datadir=/data --plugin-dir=/usr/local/mysql-5.5.15/lib/plugin --user=mysql --log-error=/var/log/mysqld.log --open-files-limit=65535 --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/lib/mysql/mysql.sock --port=3307 < /dev/null >> /var/log/mysqld.log 2>&1 >> /var/log/mysqld.log 2>&1 >> /var/log/mysqld.log 2>&1
mysql> 110819 13:23:05 mysqld_safe Number of processes running now: 0
110819 13:23:05 mysqld_safe mysqld restarted

Does anyone know about any fix?

How to repeat:
Install MySQL 5.5.15 using binary or source code, and run the crash me test OR run the test framework

Suggested fix:
dont know
[22 Aug 2011 14:54] MySQL Guru
it fails crash-me test
[23 Aug 2011 20:53] Miguel Solorzano
I couldn't repeat with current source on Fedora 14 X86_64.
[24 Aug 2011 14:19] MySQL Guru
I tested it on CentOS too, it crashes the server.
[24 Aug 2011 14:19] MySQL Guru
please let me know if you need more details about the OS configuration etc.

Thanks.
[30 Dec 2011 18:37] Valeriy Kravchuk
Please, check if the same problem still happens with a newer version, 5.5.19.
[31 Jan 2012 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".