Bug #62141 Workbench Installer cannot detect that Visual C++ 2010 is installed.
Submitted: 10 Aug 2011 20:21 Modified: 19 Apr 2012 22:18
Reporter: Jonathan Cook Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench Severity:S1 (Critical)
Version: OS:Windows (Win 7 64 bit)
Assigned to: CPU Architecture:Any

[10 Aug 2011 20:21] Jonathan Cook
I have installed the Microsoft .NET Framework 4 Client Profile and Microsoft Visual C++ 2010 Redistributable Package (x86)but the MySQL Workbench installer does not recognize that the VC++ package is installed. The installer will not continue.  This problem does not exist when installing on WinXP. I don't have a 32-bit Win 7 machine so I don't know if it works there.

How to repeat:
Install prerequisites from links on http://wb.mysql.com/workbench/wb52_prerequisites.php

Download mysql-workbench-gpl- from link on http://www.mysql.com/downloads/workbench/ and attempt to install it.
[10 Aug 2011 20:30] Jonathan Cook
Prerequisite installation confirmation

Attachment: Prerequisites.png (image/png, text), 158.13 KiB.

[10 Aug 2011 20:30] Jonathan Cook
MySQL installation error

Attachment: MySQL install error.png (image/png, text), 35.19 KiB.

[10 Aug 2011 22:21] MySQL Verification Team
I couldn't repeat on Vista 64-bit.
[11 Aug 2011 22:23] Jonathan Cook
I turned on logging to look for errors and I found this in the log:
Ignoring disallowed property CPP_100_RUNTIMES

A search on the web turned up this information:
The properties that you want to pass from UI to Execute sequence must be listed as being secure. To do this, add a property called SecureCustomProperties and enter a list of your properties (delimited by semi-colons) as value.

I then used InstEd to edit the .msi and add CPP_100_RUNTIMES to the SecureCustomProperties. The install worked after that.
[11 Aug 2011 22:26] Jonathan Cook
Log file with error message: Ignoring disallowed property CPP_100_RUNTIMES

Attachment: MSIef095.LOG (application/octet-stream, text), 296.73 KiB.

[12 Aug 2011 7:42] Valeriy Kravchuk
Thank you for detailed analysis of this problem.
[6 Sep 2011 17:13] Christopher Barney
I am having the same problem on Windows 7. Please advise. Thank you.
[13 Sep 2011 13:21] Amr Darweesh
For Windows 7 64bit you might downloaded the 64bit files only.
That will not work.
the MySQL workbench application is a 32bit application.
So, although you have a Win7 64bit. download & install the 32bit packages:

It worked for me.
[9 Nov 2011 9:56] Remco Siemonsma
I had the same problem on Windows Vista 32 bit.

I changed the installer in the way Jonathan Cook described and the installer worked.
[20 Dec 2011 10:56] Alan Smith

sorry for not being up to speed on this stuff but I have a vista 32 bit machine and get the error describes here.  Where do I go to add to SecureCustomProperties?  Thanks
[20 Dec 2011 15:18] Jonathan Cook
Here are some more details on how to edit the mysql.msi file.
1. Download InstEd from http://www.instedit.com/download.html and install it.
2. Run InstEd and open mysql.msi
3. Select the tables tab in InstEd and scroll down to the "Property" table.
4. The properties will be displayed in the right side of the window.  Select the one called "SecureCustomProperties" (You could also use CTRL+F and search for SecureCustomProperties)
6. Save mysql.msi.
After the edit you can double click on mysql.msi in windows explorer to launch the installer.
[25 Jan 2012 22:27] Danny Diaz
I'm on Windows 7 and had the same issue.  I followed Jonathan Cook's steps and it worked after I modified the .msi file.

[19 Apr 2012 22:18] Philip Olson
Fixed as of 5.2.40, and here's the changelog entry:

On Microsoft Windows, the MySQL Workbench installer would sometimes not 
detect where "VISUAL C++ 2010" was installed. 

A workaround is to append "CPP_100_RUNTIMES" to the "eCustomProperties" 
property in the .msi file.
[6 Apr 2017 7:27] Jokin Astobiza
Same case here:
Being on Windows 10 Pro 64 Bits, I have be successfully using the portable version, but I wanted to try the installed one.
So a moment ago I downloaded MySQL Workbench 6.3.9 (64 bits) and tried the installer.
I got the error stating Visual C++ Runtime was missing.
Using the installer's component checker's links, I downloaded both 32 and 64 versions of the installer. I already had them, but reinstalled anyway.

I had to follow Jonathan Cook's procedure to make it work: easy, exact and useful. Thank you a lot!
[25 Apr 2017 17:26] davi gonzaga junior
Hello guys, I have installed using the software "InstEad It!" version "InstEad-". In InstEad, open the Mysql.msi and go to "Tools>Admin Install", execute and follow the instructions.

Best Regards!
Davi G. Junior
[26 May 2017 14:35] Venkata Rama Krishna Chinni
Hi Jonathan,

I encountered the same problem while installing MySQL workbench on my Windows 7, 64 bit OS. I tried the steps provided by you by installing InstEd software and tried to change the SecureCustomProperties. But still the problem was not resolved and am unable to install MySQL workbench. 

Currently my SecureCustomProperties looks like below.


Please see if you can help me anything with the issue. Thanks in advance.