Bug #62033 Can't connect to 64 bit ODBC connection from SSRS 2005
Submitted: 29 Jul 2011 21:57 Modified: 1 Aug 2011 18:52
Reporter: Jessica Lindsay Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version: OS:Microsoft Windows (Windows 7 (64 bit))
Assigned to: CPU Architecture:Any

[29 Jul 2011 21:57] Jessica Lindsay
Description:
Trying to run a report, that was working on my old XP system, gives me this error in SSRS 2005:
"An error occured during local report processing.
An error has occured during report processing.
Cannot create a connection to data source 'MySQL_InquiryRepository'.
ERROR[IM014] [Microsoft][ODBC Driver Manager] The specified DSN contains an architecture mismatch between the Driver and Application."

Old system info: Windows XP (32 bit), ODBC Connector (32 bit), Net Connector (32 bit)
New system info: Windows 7 (64 bit), ODBC Connector 5.1.8 (64 bit), Net Connector 6.4.3 (32 bit)

I tried uninstalling the ODBC 64 bit connector and installing the 32 bit connector, but if I do that I don't see a MySQL ODBC driver in the list to create a new ODBC Data Source.

How to repeat:
1. On a Windows 7 (64 bit) computer with SSRS 2005 install:
  -ODBC Connector 5.1.8 (64 bit)
  -Net Connector 6.4.3 (32 bit)

2. Create an ODBC connection
  -Control Panel
  -Administrative Tools
  -Data Sources (ODBC)
  -System DSN
  -Add: MySQL ODBC 5.1 Driver

3. Open report project in SSRS 2005
  -Create report that references MySQL ODBC connection
  -Click "Preview" in that report
  -Get error

Suggested fix:
64 bit Net connector?
[30 Jul 2011 13:50] Reggie Burnett
Changing the category to be ODBC
[30 Jul 2011 13:51] Reggie Burnett
Changing the category to be ODBC
[1 Aug 2011 16:55] Jessica Lindsay
When I open a shared data source in SSRS and click the edit button, my MySQL ODBC connections do not show up in the list for "Use user or system data source name"
[1 Aug 2011 16:57] Jessica Lindsay
Creating the ODBC connection as an User DSN, instead of a System DSN, fixed this.
[1 Aug 2011 18:13] Lawrenty Novitsky
Lindsay, I think you have to install 32bit driver. To see it in the list of drivers, you need to run "Data Sources(ODBC)" for 32bit applications.
it can be found in your %windir%\syswow64 directory. the name of application is odbcad32.exe
Run it and configure your data source there.
[1 Aug 2011 18:17] Lawrenty Novitsky
oh, didn't see that the problem had been already solved... although that is strange that switching to User from System DSN could help with the type of error your reported.
[1 Aug 2011 18:53] Jessica Lindsay
I think it has something to do with how Windows 7 handles permissions.  

When I tried to update my connection (Shared Data Source -> Edit -> Use connection string -> Build -> New) I got this error: "You are logged on with non-Administrative privileges.  System DSNs could not be created or modified."  Once I clicked ok, it gave me a "Create New Data Source" pop up, where only User Data Source was selectable.