Bug #62024 I cannot make connection to my intranet server.
Submitted: 29 Jul 2011 8:09 Modified: 1 Aug 2011 6:39
Reporter: Eunseon Song Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.34CE OS:Windows (7)
Assigned to: CPU Architecture:Any
Tags: 10061,, Connection, connection error

[29 Jul 2011 8:09] Eunseon Song
I used MySQL Workbench to connect in my intranet server(linux), 
and I liked this program.
However, suddenly the connection was not working.
I showed this alert window.
Cannot Connect to Database Server

Your connection attempt failed for user 'mysql' from your host to server at
 Can't connect to MySQL server on '' (10061)


After, i cann't connect using Workbench.(other program like SQLyog Commuity make connection well, and no problem in my linux server.)
'Start Command Line Client' is working well, but 'Query Database' is not working.
I checked my workbench version, and it is the most-recent one.
I also tried to remove Workbench and re-install it, but the bug is not fixed.
(I'm using other function(modeling, ...) well, only connection is problem.)
I have no idea to solve this problem and I cann't search this information.
I'm not sure the reason why this problem occur, 
but I experienced 'the workbench is not responding...' message (like other windows app. sudden exit error message) twice.
The error msg. occured when modeling working, but this might be related with my problem...

I hope you give the solution to me.
Thanks in advance for your answer.

How to repeat:
I don't know why this problem occured.
[29 Jul 2011 8:11] Eunseon Song
tag modified
[29 Jul 2011 10:19] Valeriy Kravchuk
Do you use ssh port forwarding? I wonder why both and are mentioned in the error message...
[29 Jul 2011 14:02] Eunseon Song
I wonder it, too....T-T
I used ssh connection for linux server.
Before this problem, it made connection well.
There was no change between before and after.
[29 Jul 2011 14:15] Valeriy Kravchuk
Please, check (with netstat -a, for example), that ssh connection exists. Maybe sshd does not work on your Linux server for some reason...
[29 Jul 2011 14:18] Eunseon Song
I can connect my server with command mode of Workbench, other mysql program, or putty.
There is no problem...
[29 Jul 2011 14:18] Peter Laursen
I wonder if there is an orphaned executable running occupying and blocking the local port used for SSH-tunnel. I don't know to well how SSH tunnel in WB is implemented except that it uses a Python libary, but not in what process this library is linked and also not how it chooses what local port to use.

Did you try to reboot the machine?

(not a MySQL person)
[29 Jul 2011 17:10] Mike Reid
I run into a similar error (on Mac), but ONLY when I attempt multiple connections at a time. (such as to different database servers, etc.)

Just filed a report for this here: http://bugs.mysql.com/62029

Do you have multiple connections open when it's failing, by chance?
[1 Aug 2011 6:39] Eunseon Song
Thanks for your replies:)

I solved this problem by connecting other account of my linux server for SSH.
'mysql' account is only for DB, so SSH connection(port 22) was failed.
Other program has no need to connect SSH so they was working well.
(The difference between before and after might be my account or server setting, but I don't know exactly...)

I think the error msg. including '' is not proper.
It looks like the Workbench cannot get my inputting address.