Bug #62009 Workbench5.2.34CE/Windows7 crashes when connecting after a period working fine
Submitted: 27 Jul 2011 22:44 Modified: 17 Oct 2011 7:14
Reporter: Jeanne Bachman Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:5.2.34 CE OS:Microsoft Windows (Windows 7 x64)
Assigned to: CPU Architecture:Any
Tags: connect, crash, sql editor, Windows 7 x64, Workbench 5.2.34 CE

[27 Jul 2011 22:44] Jeanne Bachman
Description:
When I installed Workbench, it worked fine for a week, then unexpectedly when I tried to make a connection to my local MySQL server in the SQL editor the program crashed with the following arror:

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	MySQLWorkbench.exe
  Application Version:	5.2.34.7780
  Application Timestamp:	4ddbbfe9
  Fault Module Name:	wbprivate.be.dll
  Fault Module Version:	0.0.0.0
  Fault Module Timestamp:	4ddbbeb7
  Exception Code:	c0000005
  Exception Offset:	000070ce
  OS Version:	6.1.7600.2.0.0.768.3
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

I could use the other program modules (i.e. admin, modelling) without problems. I tried disabling my fingerprint reader, using stored profiles, new profiles, typing the parameters manually and creating a new MySQL user, all with the same result. I tried "repairing" the app (an over the top install through add/remove programs in the Windows control panel). No good. I completely uninstalled and reinstalled the app. Bingo!

About two weeks later the same problem recurred. Before reinstall I decided to try running under my administrator account. It works, but I don't know for how long. 

How to repeat:
The trouble seems to be in the code that varies per windows user account. The bug doesn't immediately appear when the workbench is installed, but once it does appear it happens every time I attempt to connect from my Windows user account in the SQL editor.

Suggested fix:
No Idea!!
[28 Jul 2011 0:01] MySQL Verification Team
Could you please provide the output of Help->System Info. Thanks.
[28 Jul 2011 19:15] Jeanne Bachman
MySQL Workbench CE for Windows version 5.2.34

Configuration Directory: C:\Users\Sinthia\AppData\Roaming\MySQL\Workbench

Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE

Cairo Version: 1.8.8

Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.

OpenGL Driver Version: 4.0.10188 Compatibility Profile Context

OS: Microsoft Windows 7 Home Premium Edition (build 7600), 64-bit

CPU: 4x Intel(R) Core(TM) i5 CPU       M 460  @ 2.53GHz, 5.8 GiB RAM

Active video adapter: ATI Mobility Radeon HD 6370   

Installed video RAM: 512 MB

Current video mode: 1600 x 900 x 4294967296 colors

Used bit depth: 32

Driver version: 8.771.1.0

Installed display drivers: atiu9p64.dll,atiuxp64.dll,atiuxp64.dll,atiu9pag,atiuxpag,atiuxpag,atiumdva,atiumd6a.cap,atitmm64.dll

Current user language: English (United States)
[4 Aug 2011 21:11] Dave Power
I've experienced a similar problem on Windows Vista.

However, I've found that creating a new connection to the localhost/database schema has fixed the problem.  So the problem could be linked to a corrupted database connection.
[7 Oct 2011 7:18] Valeriy Kravchuk
Please, check if the same problem still happens with a newer version, 5.2.35.
[16 Oct 2011 4:40] Jeanne Bachman
I installed the newest version and it seems to have resolved the problem. I will let you know if the problem recurs, but this seems to have done the trick. Thank you so much for your prompt resolution to the problem. It really means a lot to me. This is why I maintain my decision to switch to MySQL.

I also would like to say that the new windows installer is a real improvement. Very polished. It was much easier to determine what components have updates available, and the visual appearance is much improved. Keep up the good work.
[17 Oct 2011 7:14] Valeriy Kravchuk
Looks like the problem is not repeatable with 5.2.35. Please, re-open this report in case of similar crash with 5.2.35 or newer version.
[22 Dec 2011 16:39] Claudius Steinhauser
I have exactly the same error on Win7 X64 using version 5.2.36
Is there a workaround?

Problem Event Name:	APPCRASH
Application Name:	MySQLWorkbench.exe
Application Version:	5.2.36.8542
Application Timestamp:	4ed8d0ff
Fault Module Name:	wbprivate.be.dll
Fault Module Version:	0.0.0.0
Fault Module Timestamp:	4ed8cd32
Exception Code:	c0000005
Exception Offset:	000309a6
OS Version:	6.1.7601.2.1.0.256.48
Locale ID:	1033
Additional Information 1:	0a9e
Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
Additional Information 3:	0a9e
Additional Information 4:	0a9e372d3b4ad19135b953a78882e789
[22 Dec 2011 16:52] Claudius Steinhauser
After downgrading to 5.2.34 I can connect again just fine. No saved setting were lost. The older version just works.
[29 Nov 2012 9:04] Sheldon Neilson
I'm experiencing the same issue with 5.2.44. A full MySQL re-install did not solve the problem:

Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: MySQLWorkbench.exe
P2: 5.2.44.9933
P3: 50637ee4
P4: wbprivate.be.dll
P5: 0.0.0.0
P6: 50637bc6
P7: c0000005
P8: 000ce5ee
P9: 
P10: 

Attached files:
C:\Users\Sheldon\AppData\Local\Temp\WER7D69.tmp.WERInternalMetadata.xml

These files may be available here:
C:\Users\Sheldon\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_MySQLWorkbench.e_e6c14d90b49085db3869bb2baddccd771e3ba2a_29c98a45